Strange Layout Performance Issue

I have always had some issues with the performance of layouts with clipped geometry and had accepted this to be an unfortunate reality of using Rhino/VisualArq.

However, I have noticed that when the layout is zoomed out a certain amount (I have a 4k laptop display FYI) such that the entire page with some border is visible - the performance is great. Panning is smooth and any attempt to draw geometry or annotation works fine.

If I zoom in even a single increment from here (so aesthetically I can’t see any difference in the content) the performance suddenly takes a massive hit and everything becomes so laggy it is extremely frustrating to use. I’m talking maybe 2-3fps - and this affects not just panning, but drawing and annotations as well.

I suppose this must be some kind of resolution scaling - but I would gladly lower the resolution to get back the lost performance as this really just makes things so difficult when trying to work on layouts.

Is there any fix/workaround for this? Has anyone else had similar issues?

Hi Ben -

What happens when you create a new file with VisualARQ disabled? Can you reproduce the performance hit?
Also, please run the Rhino SystemInfo command and copy-paste the result here.

Hi Wim,

I have just opened the same file with VisualArq disabled and yes, the performance is much better. You can still feel a slight performance hit at the same zoom levels, which implies that whatever display scaling is still happening. However the performance is still good and manageable at all levels of zoom.

Two differences with and without VisualArq - Hidden display mode and the plan cut view are unavailable, so I used Shaded mode and a Rhino clipping plane.

I suppose that these must be responsible for the performance hit. But I feel that this is a bug, as it’s not really a huge complex model with tons of hatches etc.

@fsalla Is it possible to somehow resolve this issue, as currently annotating sheets with this issue is very frustrating!

If it’s still relevant, here is the system info:

Rhino 7 SR20 2022-6-14 (Rhino 7, 7.20.22165.13001, Git hash:master @ 791285d0b70d4a1627313cfc9d0e6e8bd9acc6d4)
License type: Commercial, build 2022-06-14
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 1-22-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 2070 with Max-Q Design (NVidia) Memory: 8GB, Driver date: 3-17-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.15
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-17-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.20.22165.13001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.20.22165.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.20.22165.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.20.22165.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.20.22165.13001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.20.22165.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.20.22165.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi @Ben_B, can you share that file so we can figure out what’s causing that slow performance? You can send it to