Stop object snapping to stuff behind?


#1

sorry i’m not sure the best way to phrase this, but can I have object snap only snap to the objects in the front? it keeps picking up 10000 things in the background, even on rendered and solid modes.


What the Gumball so badly needs [SOLVED]
(Pascal Golay) #2

Hi arch - currently, no, there is no way to do this I’m afraid.

-Pascal


#3
  1. My technique is to ‘let it snap.’ As long it looks good from the view you are using, you can always straighten the curve back out flat in one command: Transform ► Project to CPlane.

  2. Don’t forget you can hit ALT to turn off all OSnaps during any command. Let go to resume.

  3. After the above is complete, I usually still make tweaks to the curve. So, being accurate ‘all at once’ is not something I worry about. I assume there will be edits.


#4

It’s very difficult to scale things currently. Simple objects – I’m just trying to push/pull solid rectangular pieces. I’ve tried 4 methods and all of them suck. Scale 1d means I have to select 2 points then click somewhere, but the object snap selecting everything makes it difficult to select the two points on the object. Turning solid points on has the same issue, which can be made slightly easier by filtering only control points, but then 4 points instead of two. The gumball scaler scales from the center of the object, so i have to move it to the corner every time which is really obnoxious. Control + Shift clicking a face also doesn’t work because the millions of things behind confuse the program. It often shows everything except the one face in the very foreground that I want to select.


#5

this one comes in handy at times:


#6

Hi Arch,

This would definitely be nice, but as Pascal has indicated not possible. What I usually do is have 4 views on, and as I select in one view I go to another view (usually top) and marque deselect (right to left) what I don’t want while holding the control key down. Doesn’t work in all cases, but usually does.


#7

That’s discouraging. I now use Rhino for 2D drafting and when I have to create complex geometry but when I have to create complex assemblies of parts which are not, in and of themselves complex, I do so in other modeling programs and then, if necessary, import into Rhino.

On a somewhat related note: I’m wondering if there’s a way to avoid the problem in the attached image. Is there an Apparent Intersection snap that I’m not aware of that I can turn off?

.


(Pascal Golay) #8

Hi Arail- yes, in Options > Modeling aids > Use apparent intersections.

-pascal


(Pascal Golay) #9

I don’t know if it might help to keep a clipping plane(s) handy and adjust its depth according to what you are working on- Osnaps are culled by clipping planes.

-Pascal


#10

maybe try _MoveFace ?
start the command before selecting then the selection prompt will only allow surfaces… use the normal constraint (which will act like push/pull)… no need to click a ‘move from’ or ‘move to’ point with that… type the distance.


#11

Thanks pascal - that’s a big help.


#12

That is a great tool. Had to look up what it did. Thanks.


#13

I concur with the OP here that it would be very useful if Rhino could somehow give priority to the closest object to pointer.


#14

Yes, in complex files (I have one currently) snapping “through” shaded objects to something behind is a large nightmare, I keep having to turn on and off sets of layers to be able to work.

–Mitch


#15

there are several recurring problems i have in rhino, but none is more dangerously time-consuming and frustrating than fighting with the software so as to correctly locate points, lines, planes. it is something that the software developers would be wise to address. otherwise, the program will fail.
other problems involve objects mysteriously moving from one layer to another, unlocking themselves [i haven’t had a case where a layer spontaneously locks itself. perhaps the second biggest weakness with the software’s design is the persistence of objects being kocked out of position. i have tried to draw a dodecahedron a number of times, but its pentagonal faces [which are no easy thing to draw] repeatedly drift in space. often this drift is small enough so that it doesn’t become apparent until after much time has been invested in developing the figure


(Wim Dekeyser) #16

How is your reply about “snapping to stuff behind”?

Please start new threads for any problem that you have.

Also, in order to be able to fix any bug in Rhino, you will need to explicitly describe the necessary steps to reproduce the problem. As a general rule, also post a file that exhibits the problem.

As far as I can tell from your description so far, these are cases of user error.


#17

That just made my day! 20 years experience and still learning…:smiley:


#18

Hi Jeff, Sorry for the delay but I thank you for your comment. “Move face” is something I will use from now on until they fix snapping.