Ignoring Osnaps on background objects

I get very frustrated by trying to snap to an object only to find out I’m snapping to something in the background. I know object snaps highlight the feature it is snapping to, but if there is an object that has something like 10,000 features I want to avoid, it is fairly difficult. Is there anyway to disable snaps to objects that aren’t immediately visible on the viewport when using a shaded view? It’s not always feasible to hide certain objects because I’m most likely needing to work around the object. Am I just going to be frustrated?

Thank you.


Hi Jay- this has been tuned up for V6…


I know it’s been asked a thousand times before but what is the status of V6? I just bought V5 about a month ago.