Rhino snapping struggle in 3D

Hi folks!
Is there any option that can disable “background” snapping to objects when modeling in 3D?
I have a problem very often when I have complex geometry in 3D and I need to snap to an object…since there are lot of object behind (that are not visible) my snaping object /point, I always struggle to find the right point to snap to. Any chance that Rhino can prevent snapping to object that are “behind” or not visible in your current view?

left click on Osnap in the status bar
disable “snap to occluded objects”

image

commandline: SnapToOccluded

Anika thank you very much!
Wich version Rhino R U using?

Rhino 6 / and right click on Osnap

Well, one major problem with Rhino 6 is that it’s ability to snap to objects is worse than that of Rhino 5. If you turn the “Snap to occluded objects” off, Rhino 6 will fail to snap to objects that are on a surface whose render mesh is covering the actual NURBS geometry. Here is an example 3d file.

Rhino 5 snap is better than Rhino 6 snap.3dm (58.4 KB)

I projected a straight line over a bent extrusion and now in 90% of the time Rhino 6 can’t snap to the projected line, even though it was supposed to work. The only solutions to this issue currently are:

  1. To increase the file’s or object’s rendering mesh density (not a good option to do on complex models or waste time for every newly created surface).
  2. To turn on the “Snap to occluded objects” which brings the problem with snapping to random objects behind (if any).
  3. To rotate or zoom-in or zoom-out the camera until Rhino 6 finally “sees” the projected line through the rendering mesh of the NURBS surface.

Another problem with Rhino 6’s rendering solution (again, compared to Rhino 5 were everything was fine) is that when a NURBS surface or model is set to “wireframe” rendering mode through the “! _SetObjectDisplayMode” command and user wants to rotate the camera view around some other object behind the wireframed surface or model, the center of rotation still snaps to the latter even though it was supposed not to since the rendering mesh for this particular surface or model is invisible. In Rhino 5, the center of rotation ignores the invisible rendering mesh and properly snaps to the object(s) behind. This issue in Rhino 6 happens both with using the RMB of the regular mouse or with a 3d mouse like 3dconnexion.
For example, if you make the walls of a house seen as wireframe mode while working on other models inside the house (furniture, stairs ets) in a Shaded or custom view mode, Rhino 6’s automatic center of rotation may behave unpredictable.

Hello - if I understand your comments, the snapping problems you describe are with the Snap to occluded turned off, correct? If you see differences with Snap to occluded on in V6 and the V5 behavior, that would be something to look into.

-Pascal

Hi Pascal, in the past I was working in a company with Rhino 5 and it behave perfectly fine with the snap. However, last year, at the moment I tried Rhino 6 evaluation I immediately noticed that it has problems with snapping to projected curves over surfaces (or extracted isocurves), and it seemed related to the rendering mesh itself that hides the projected lines in some areas. Is there a way to work around this issue (maybe tweaking the Z-buffer?) and allow Rhino to “see” through the rendering mesh of the nearest surface to the camera, while still being unable to snap to objects that are 2 or more millimeters behind the mesh?

Hello - right, but my question is, are you comparing Snap to occluded OFF in V6 with V5 behavior? If you turn on Snap to occluded in V6, does it behave as in V5?

-Pascal

Snap to occluded is only available in V6?

sub, 5. sij 2019. u 22:03 Pascal Golay mcneel@discoursemail.com napisao je:

Hi Pascal, I just downloaded Rhino 5 90-day trial from here https://www.rhino3d.com/download/rhino/5/latest and now I compared how it behaves. As mario_pende pointed above, there is no option to turn off snap to occluded objects in Rhino 5. However, I see that in Rhino 5 it’s much more predictable to snap to nearby objects when there are other objects behind. It feels like Rhino 5 prioritizes the nearby objects and surface edges over the distant ones hidden behind. In Rhino 6, it’s quite difficult to snap to nearby objects or edges when there are objects behind.

I found out something strange in Rhino 5 now. When I try to set a custom render mesh and hit “OK”, the program refuses to do so and keeps the detailed mesh given it by the general mesh settings. Here is a screen-shot of the mesh settings. I tried many other settings, but none of them were accepted by Rhino. I have never seen his before.

Rhino%205%20custom%20mesh%201