Import .stp Files

Hello Everyone,

I’m working on a project that involves importing 3d models and running energy simulations with grasshopper with Rhino. Even before we get to any meshing issues (as I’ve noticed in a few previous posts) with importing files of other formats, I’m having trouble actually importing the .stp files. I saw here that Rhino supports .stp but cannot seem to find the format under the “Supported File Type” dropdown list under File > Import (or Open). Am I missing a step or doing something wrong?

I’ve also tried to use the plugin CADExchanger from food4rhino with little success due to the license being expired. Would greatly appreciate any tips or help you’d be able to give!


Hi Mike - you should certainly see stp/step in the import/open file types- my list looks like this, plus some more off the top:

Do you see any of those?


Hi Pascal

Unfortunately this is all I see from the import screen.


Hi Mike - so, all the file I/O plug-ins are failing to load - can you please close Rhino and run a repair on the installation (Via the Windows control panel) and then start it again?



This brought up an interesting error! I am fairly certain (by virtue I can browse the web etc.) that I am that I am indeed connected to the internet.

Any suggestions?


Hi Mike - can you run the SystemInfo command in Rhino and copy/paste the results here?


Here you go!

Rhino 7 SR6 2021-5-7 (Rhino 7, 7.6.21127.19001, Git hash:master @ aec74c050f3ca28ab3cfd6882e9453a52366a9b7)
License type: Commercial, build 2021-05-07
License details: Cloud Zoo

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.

  • Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-5-2020 (M-D-Y).*
  • Integrated graphics device with 3 adapter port(s)*

  •    - Windows Main Display is laptop's integrated screen or built-in port*
  •    - Secondary monitor attached to adapter port #1*
  • Primary OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 4GB, Driver date: 6-21-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 398.35*
  • Integrated accelerated graphics device (shares primary device ports)*

  •    - Video pass-through to primary display device*

OpenGL Settings

  • Safe mode: Off*
  • Use accelerated hardware modes: On*
  • Redraw scene when viewports are exposed: On*
  • Anti-alias mode: 4x*
  • Mip Map Filtering: Linear*
  • Anisotropic Filtering Mode: High*
  • Vendor Name: NVIDIA Corporation*
  • Render version: 4.6*
  • Shading Language: 4.60 NVIDIA*
  • Driver Date: 6-21-2018*
  • Driver Version:*
  • Maximum Texture size: 32768 x 32768*
  • Z-Buffer depth: 24 bits*
  • Maximum Viewport size: 32768 x 32768*
  • Total Video Memory: 4 GB*

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino

  • C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.6.21127.19001*
  • C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit” *
  • C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.6.21127.19001*
  • C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.6.21127.19001*
  • C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” *
  • C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots” *
  • C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.6.21127.19001*
  • C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.6.21127.19001*
  • C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse” *
  • C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”*


Hi Mike - thanks - nothing very revealing there, to my eye anyway - I think I would bite the bullet and uninstall & reinstall the latest-


Pascal, understood, thanks for the help. I’ll give it a shot and let you know how it goes!


That seemed to do it, thanks Pascal. Solved!

1 Like