Space visibility in print- detail

hey! has anyone else had space elements disappear in a print layout?
they are totally visible in my plan viewports.

and it shows up just before printing as well some times. !
its the erratic nature of the error thats foxing me. i could potentially go around it by using grasshopper preview to have them show up and turning off the layer they are on- but before i do that i wanted to check if this is a bug or just me.

@aditya.d.bhatt try to update those spaces with the vaUpdate command, and see if problem persists.

Hi Francesc,
any update on the spaces bug yet?

Hi -

Does that mean that you tried the vaUpdate command?

i did but that doesnt work. :frowning:

Thanks for confirming that.
Could you post a minimal 3dm file that illustrates the issue?
Also, are you up-to-date on your Rhino and VisualARQ versions?

1 Like

Hi Aditya, no news yet on this bug. We are still revising it. I’ll let you know we fix this.

@wim, I’ve got already an example from Aditya.

1 Like

okay now it does. very wierd. I rebuilt all of the elements around the offending spaces and it works fine now. (i.e they print correctly)
The bug that remains (francesc just addressed that) however is another one that i think i posted on a separate thread- the spaces detect boundaries from floors above and below. I have bypassed this problem temporarily by moving them away from each other.

thanks @fsalla. FYI I am unable to ‘sendtoback’ for the spaces while printing, so they end up hatching/colouring over objects like stairs in top view - i havent been able to subtract my stair from the space by using the elementunset command yet.

Hi Aditya,
We will revise the problem of “sendingback” the space pattern below the other 2D geometry in plan views.
Regarding the other issue, you need to use the vaSpatialObjectSet command (not the “unset” one).
I’ve tried it on your file, using a rectangle as new spatial object set, and it works fine. If it doesn’t work for you, please send me the model with the geometry involved.