Sometimes dimensions lose "draworder"/ Rhino (render?) is confused?

unhandled

#1

Rhino.ini (141.3 KB)
3D Model.3dm (5.9 MB)

It’s super annoying to move dims forward infront of surfaces to make them shown properly. And I HATE BringToFront as it’s applied globally and not per view.


#2

Yep, that’s true. Also would be nice to have something like “annotation to the front” and “hatches to the back” command.


(John Brock) #3

@Asterisk
I’ve opened your file in the current in-house WIP.
I have not used your “Rhino.ini” file.

When I go into the two Layouts in your file, I am not seeing the chopped up dimensions you show in your image.

PRECISELY, what do I need to do to duplicate the problem here?


#4

Same here nothing wrong with dims, i use constantly dims and never had visual problems. Maybe your graphic card issue or fonts that u use have problems.(Rhino 5SR13 64bit)


#5

Use my “Printed” display mode and plot it to PDF. But you will be able to see dimensions being clipped in layout at different zoom levels already. This is in V5.


(John Brock) #6

@Asterisk
Export just your “Printed” display mode and send the ini file for that please.


#7

Printed.ini (11.6 KB)

Keep forgetting I can export just the display modes…


(John Brock) #8

Since the category is “Rhino for Windows” can I assume this is for Rhino V5 and not the V6 WIP?


#9

Correct. Hoping it’s something I can fix on my end. Oh yeah, the whole engineering dept suffers from this issue from time to time.


(John Brock) #10

Since it’s V5, there isn’t anything we can do about another service release even if we can find a problem.
The display code for V6 is completely rewritten.
Please try duplicating your setting in V6 and see if it works there.


(John Brock) #11

I am getting a strange Layout display in V6 so I’ve sent that to the developers.


#12

Does the screen just go black when you try to change the display mode to printed? That’s what I get in V6.


(John Brock) #13

Yes.
https://mcneel.myjetbrains.com/youtrack/issue/RH-41222


#14

The issue in V5 only appears when the view is set to true Top Down/perpendicular to surface+dim.
At any other angle of zoom level dimension is always drawn over the surface.


(John Brock) #15

I’m seeing that here.
Setting a smaller TestZBiasFactor seems to help but does not fully fix it.
When I Zoom to a place where a dim doesn’t show. bumping the TestZBiasFactor seems to help.
Not much of a work-around but that’s all I have right now.