Some weird behaviours (aka Bugs) when undoing/redoing in blocks

Follow along with these steps to see some weird things happening:
Draw a box and turn this into a block:

Now draw a few more objects next to it which you don’t turn into blocks (I used spheres here to distinguish blocks (boxes) from non-blocks (spheres)):

Now run the BlockEdit command on the earlier created block and immediately Undo. I first get 2 pop-up messages. This is the first:

And this is the second:

Bug 1: Do we really need to get 2 pop up messages for this instead of 1? (I’d also argue for having even 0 pop-up messages for this but I get in some cases it’s good to be aware of undoing things before starting to edit the block)

Let’s continue. After pressing Ok 2 times to get rid of the pop up windows, Rhino went out of BlockEdit mode and removed my last created sphere. The Block Edit window is still open but I cannot do anything with it, except for pressing the “X” button to close it:

Bug 2: Why doesn’t the BlockEdit window close automatically if it’s currently inactive and useless?

I close the BlockEdit window with the X-button and press Redo to get the sphere back and this is what happens:

Rhino puts the sphere back in place and locks everything except for the block that I was trying to edit before. It seems like I am in BlockEdit mode, but the BlockEdit window is not showing.
Now even if I redo this last step without closing the BlockEdit window I get the same result with an inactive BlockEdit window:

Bug 3: Rhino seems to try to redo 2 commands at once but screws up the blockedit command: it brings back the sphere and locks all objects as if I’m going back in BlockEdit mode. But at the same time it’s not showing the BlockEdit window (active) so I’m not sure if I am even editing this block, and if it even is a block. When I select it it’s showing me it’s an extrusion, which would indicate I’m inside the BlockEdit command. At the same time I don’t know how to go out of this current active BlockEditing mode?

There’s a lot of stuff going wrong in these steps (things get even weirder when you draw another block, go into blockedit mode and start undoing and redoing) and I’ve had this happening quite often where I end up in a situation where I’m forced to either unlock all objects and lose the block I had before or undo and lose the last step I was doing before block edit.

Hello - thanks, I’ll take a look. I see this… I suspect an Undo after running BlockEdit and doing nothing else was just not… envisioned.

RH-58747 BlockEdit labyrinth


The example was just an easy way to show the problem. I run into this when I’m going a block, do some stuff and then realize I need to undo some stuff and then undo 1 step too far back.

Just so you know, that youtrack item is not visible to public.

Fixed that, thanks.