Black viewports that dont update

Hi I started another free trial with rhino 6 with a different email address and it downloaded fine and said I had my 90 days but when I open it the viewports are black and they only update a frame when I click somthing. So its unusable.
What can I do? Iv looked and some people say its somthing to do with my openlg but my settings seem to not match that of others and some people say its the driver or somthing but I tried update it but it said its the newest one.

Please help!

Thank you

Hi @callum.blees,

Please run Rhino’s SystemInfo command and post your results here - thanks.

– Dale

Hi Dale, I ran the command as you said and this is what I got.

Rhino 6 SR27 2020-6-24 (Rhino 6, 6.27.20176.05001, Git hash:master @ ba2c30de00be5a8b210bc297715204e941911799)

License type: Evaluation, build 2020-06-24

License details: Stand-Alone

Expires on: 2020-10-18

Windows 10.0 SR0.0 or greater (Physical RAM: 3.9Gb)

Machine name: CALLUM-HP

Non-hybrid graphics.

Primary display and OpenGL: Intel® HD Graphics (Intel) Memory: 2GB, Driver date: 5-19-2016 (M-D-Y). OpenGL Ver: 1.1.0

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Anti-alias mode: None

Mip Map Filtering: Linear

Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation

Render version: 0.0

Shading Language: Not supported

Driver Date: 5-19-2016

Driver Version:

Maximum Texture size: 1024 x 1024

Z-Buffer depth: 32 bits

Maximum Viewport size: 16384 x 16384

Total Video Memory: 1851808 KB

Rhino plugins

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.27.20176.5001

C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”

C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”

C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.27.20176.5001

C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”

C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”

C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.27.20176.5001

C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.27.20176.5001

C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

You are running Rhino on an unsupported Intel display adapter.
That Intel graphics card is running and ancient (2016) driver.
I can’t find a Windows 10 driver for that long since discontinued graphics card.

There was a change in V6 SR27 that has caused problems for old, unsupported graphics cards like yours. Rolling back to SR26 might be an option until SR28 is release late this month.
Here’s a link for the SR26 installer.
You’ll need to Uninstall SR27 first.

Please consider replacing this old computer with one that meets Rhino’s System Requirements at your earliest opportunity.

hi John,

I clicked the link and installed it. I got a message from rhino saying that I had already installed the latest version?

Sorry just re read your response and you said that haha Ill try that now

You fixed it! This worked! Thank you so much, this has been stressing me for ages.

Hi John I’m completely beginner in Alias and this is my 1st time in the forum. so I’m a little bit lost, but I think i have similar problem I was working with out any problem till yesterday… and this morning I have all 4 viewports in black.
I didn’t do anything but Rhino did automatic update recently. Not sure if this could be the cause.
I would be gratefull for any help
Thank you

( I realised now of the grafic device. I will try to solve it… but till now it was working fine in this configuration)

License type: Comercial, revisión 2021-02-08
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Intel® HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 11-4-2020 (M-D-Y). OpenGL Ver: 4.3.0 - Build
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
NVIDIA Quadro K620 (NVidia) Memory: 2GB, Driver date: 11-20-2020 (M-D-Y).
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0

Desktop is using the slower, less reliable integrated graphics device and probably needs a configuration change.

An accelerated graphics device exists and is attached to a monitor, but it’s not being used by Rhino.

  • Recommended: Use Windows’ Display Settings to configure the monitor attached to the NVIDIA Quadro K620, to be the “Main Display”.
  • Any hardware configuration or cabling changes you make will require that you restart Rhino.

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 2x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.3
Shading Language: 4.30 - Build
Driver Date: 11-4-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

It looks to me like you have your monitor plugged into the Intel GPU instead of directly into the Quadro. Doh!

You may need to dig up a different monitor cable, but that should fix the problem.
I have a system like that and nothing is connected to the Intel GPU.
Both of my monitors are connected directly to the Quadro.
I have even disabled the Intel in Windows Device Manager.

That should get you sorted.

Thank you very much John. Still trying to solve it. I had a HDMi/Displayport conversor at job so I thought I could use it to plug my monitorto the quadro… but it doesn’t work.

I will try to buy HDMi-Displayport cable. Maybe I can fix it this way.

Thank you very much

My Rhino It’s working! :slight_smile: Finally i could connect the screen to the quadro with a VGA connector. So it’s working! :slight_smile: My screen has HDMI and the Quadro a displayport so here it’s where started my problems… fortunately both have VGA. so yes… after change the cable and conect them it’s works well.

Thank you very much John, for your time and advises (!!!) :slight_smile: