Viewport problems rhino 6

Rhino 6 SR11 2018-12-14 (Rhino 6, 6.11.18348.17061, Git hash:master @ 600b621e607cf5226a968db60d7ac9230541b94d)
Licence type: Commercial, build 2018-12-14
License details: Stand-Alone

Windows 7 SP1 (Physical RAM: 16Gb)
Machine name: GIANFRANCO-PC

AMD FirePro V5900 (ATI FireGL) (OpenGL ver:4.2.11753 Compatibility Profile Context FireGL)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.2
Shading Language: 4.20
Driver Date: 7-11-2012
Driver Version: 8.982.2.0
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\EasyJewels3D_rh6\EasyJewels3D.rhp “EasyJewels3D”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
I have installed rhino 6 and when i open a document sometimes viewports are black sometimes are white, sometimes only one or two are black. i tried with different settings of antialiasing and gpu tesseletion .

  1. with no tasselletion and no antialiasing if i make a curve i can see it while drawing but after creation it exists but is not visible in shaded ,in wireframe …never .
    2)with tasseletion on and no antialiasing it works but if i have an open sweep like a pipe i can see wireframe like in this attachment and if i use one of my commands that uses drawoverlay you can see the result (cyan in the attacment).
    Anyone knows what is happening?


your graphic card driver is from 2012. Update it.



1 Like

Solved, thank you Michael, i did not see it because it was one of the first thing i did !!!
I tried to check directly if they were updated without even checking which ones I had installed and the system had warned me that the drivers installed were the most up-to-date…really i don’t know why.