Solved:>>Urgent: Scripts stopped working

Hi there, while working with Rhino 5 suddenly all my custom scripts (e.g.: mainly scripts loaded from @Pascal Golay and others from the McNeel website) stopped working. The aliases still auto-complete, and the command appears in the command line, but no command is executed and no commandline menus are shown.
Interistingly if I try to run the RunScript comman the commandline shows an “unknown command” prompt…

I really need to get this sortet out asap so any help would be highly appreciated.

Thanks, Norbert

Okay that was fast.
I realized that somehow the RhinoScript plugin had unabled itself. That was what caused the problems I re-enabled it, restarted Rhino and… Voilà!
Sorry for the hassle… might be useful for someone with the same problem in the future though.

Cheers, Norbert

So scripting was working in a Rhino session and just stopped working while in the session?
Nothing else happened between working scripts and none?

Indeed, that is what happened.
I was repeatedly using Pascal’s script, to create different versions of a bent steel rod structure, when without any apparent reason the command stopped to work.

I litterally used the script on some lines I created (and it worked), then I created a slightly changed layout of lines and arcs, wanted to fillet them again with Pascal’s script and… Boom, no luck.

I wasn’t really aware that RhinoScript is a plug-in, that was why I didn’t find it disabled immediately.

Cheers, Norbert

Hmm Must be my fault… was there any error or anything from the script at any point prior to the plug-in apparently disabling itself?