Rhino Script Plug-in not working

Hey all,

I’m having trouble with the script plug-in since last update to 6.11 /resetup my system.

I’m used to having trouble while using Matrix Software and Maxwell Render on the same Rhino 5 (second licence as both softwares are not yet available for Rhino 6) as they share dlls.
Now when I start Rhino 6, it tells me that the plug-in “Rhino Script” failed to load and even if (every 7th time) I don’t get the error message, I’ll encounter the following screen when I try to run a script.
I’ve made all updates for Windows7, .net frameworks etc, just not for Matrix.
Didn’t find anything in the forum.
Anyone encountered a similar problem?

Thank you in advance


When we have seen this happen in the past, it was always related to an anti-virus program blocking this plug-in. Are you running something other than Windows Defender?

Thank you for your reply.
No, I’m not running any other Antivirus programs, but a Windows Defender definition update cannot be done by windows. Might this be a indication to be a malware?

Is Rhino Script selected in options>plug-ins ?

Good thought, but already checked that. I tried to stop using the plug-in when Rhino starts and restart it manually. same error.
tried keep using the plug-in, same error

another indicator could be that if I rightclick on the opened Rhino6 logo down in the windows bar (in my old windows 7 x64), it would show “Rhinoceros 5.0”

Hi Benedict - see if simply repairing the V6 installation from the Windows control panel helps.


Hi Pascal,

I tried to uninstall, reinstall, redeinstall , repair. None of these seemed to work. It was the main reason why i reset my whole computer including windows.
I was asking myself if there could be an better or worse order in which all these software should be installed.


Hello - I would think that if you install V6 after 5 and the associated plug-ins etc, it should just work…


I did that way. rhino5 comes with matrix and was installed through the matrix launcher thing installer. then matrix, maxwell and its thino plugin and then rhino6



Hi Ben - and, is RhinoScript the only thing not working?


seems to be the only yet, yes

@dale - any idea?


@benedict - you might consider repairing your Rhino 6 installation (Control Panel > Programs and Features > Change > Repair).

– Dale

I did. It didn’t help. Did it through the latest download from the official website as well.

Hi Ben - see if you can find the rhp in the Rhino installation folder - should be

“C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp”

Drag and drop that plug-in file onto an open Rhino window…

Does that load it?


…drag n drop doesn’t work…

Error message, fails to load?


no, not allowed by the mouse symbol… like a round interdiction circle
doesn’t work with files either. I run with admin rights

Well, little edit:

It now ( at this very moment) works fine so I can’t test it, but it’s a repeating error that bothers me since long time and seems to switch on and off randomly. I use Matrix software very rarely and it seems to appear when I used it and switches off some time later.

However, I can live with these miner problems and that software mess at the moment, hoping for updates to rhino 6 from the plug in sides soon.
I don’t blame any of the programmers guys, I’m not very surprised that this mess of different softwares and plugins don’t work properly all together.

Thank you any way for your suggestions

Aha - so, run Rhino by starting with Right-click on the icon and choose ‘run as administrator’. Then try drag and drop…