Rhino 5 stop working when using python

Hi there,

Can any one help me out with this issue? I have been using python in rhino 5 for a few years but today suddenly it causing the rhino 5 stop working… every time when I type " rs. ", rhino 5 just crash…

Did any one has encountered a similar problem like this? How can I use python again in rhino 5?
Seems no matter which rhino file I use has the same issue…

Appreciate for any suggestion,

Jack

Seems like if I run a python script it is fine but I cannot write a new script anymore, whenever I type in “rs.” after the “.” it crash…

Hi Jack - when you open the editor, is RhinoscriptSyntax available in the left hand sidebar? Can you type in the ‘Import rhinoscriptsyntax as rs’ in a new blank script? Does this autocomplete as usual?

-Pascal

Hi Pascal,

Yes, both are available on python.


I just found that some times I can run my script, but some times when I run a same script it crashes…

This issue suddenly comes up today, and I have just install a live connection plug-in between grasshopper and ArchiCAD 20. Would that be the thing that causing this issue?

If you disable the plug-in, does that fix the issue? --Mitch

Hi Mitch,
Not sure what was wrong… but when I restart the PC, python works again.
I haven’t disable the ArchiCAD plug-in or uninstall the plug-in.
But when I open rhino it told me the paneling tool stop working and ask me do I want to unload (or uninstall it ), I click ‘yes’ then I found python works again…