[SOLVED] Printing Window


#1

Hi,
I wanted to print some sections at a specific scale, and realised that the printing properties only allows a “viewport” or “extend” selection. It is thus impossible to frame my drawings correctly, or keep them at the right scale.
I remember this option was available on the last version, would it be possible to bring it back?

Thanks!


#2

Maybe I’m misunderstanding, but…


#3

I don’t get the same layout when I print… see image
Is that a driver problem?


#4

Nope… The image Dan posted is what the Print dialog looks like on Windows… I don’t have a Mac here to test, but I think printing is still being worked on, so it may not be 100% complete on the Mac side…

–Mitch


#5

Sorry, I failed to notice the Rhino for Mac tag.


#6

Happens to me fairly often as well…

–Mitch


(John Brock) #7

Mac Rhino will not have the Windows Rhino page Layout feature on initial release. We hope to be adding it later after we get Mac Rhino rolled out.
There will be no extra plug-ins available either as we do not yet have a public SDK for developers to use to write plug-ins. This also includes Grasshopper as it is developed in Microsoft DotNet.
When we get a public SDK we will use it ourselves for our own rendering plug-ins.


(Marlin Prowell) #8

Print Window is not implemented on the Mac. It has not been available in any previous Mac version.


(John Brock) #9

Maybe you meant ViewCaptureToFile or ViewCaptureToClipboard?


#10

The default is “Print selected”. First you have to select the objects you want to print, choose “print”, and the driver will then center those objects on your paper. Obviously you can only select a section that will fit on your paper size at the specified scale.

Max.
Edit: this is not correct, see my latest reply in this thread.


#12

John, I didn’t remember something so indirect. I might think of the window’s version…

Maxz, I tried to select a small part before printing, but it doesn’t center on the selection (in either “viewport” or “extents” option) :frowning:


#13

That is odd. I tried again and it works OK in “Extents” mode. It still works in"Viewport", but not centered. Yours seems to ignore the selection, did you select before hitting “Print”? Edit: ignore that question, you cannot select after hitting print.

Max.


#14

Got it. Where it says “Output and Scaling” in your printing window, change to “Visibility”. Now tick the box “Only selected objects”, and the preview will show just those and centered (for “Extents”).

Max.


#15

amazing!
Thanks Max, that was well hidden!