SOLVED: Keys not working properly since latest mac update

rhinoformac

#1

I can’t pan or zoom, and who knows what else since I just updated my mac. I’m using intuos 5 touch, I’m running OS X El Capitan 10.11.6, and this was caused by Security Update 2016-003
Anyone know what’s going on? I can’t use my Rhino 5.2.4
Thank you.

UPDATE1:
This is totally odd… I unplugged everything and restarted the Mac. Now all the caps, shift, control, etc. keys only pan… nothing else.

UPDATE2:
Tried doing it again and it’s stuck on pan. (keys work properly when I’m typing emails, etc… only don’t work properly when in Rhino)

UPDATE3:
Wacom put out a new driver. Issues fixed:)


#2

no solution, just a confirmation that this might not be the fault of rhino but the cause of just another nasty and in this case unfortunately also final update from apple before they moved further to sierra, leaving us stuck with bricked devices like a printer in my case. and what a coincidence that this forces moving to sierra leaving others behind which cant do that update anymore since sierra is not willing to be installed on older macs. oh yeah solution, go and buy another overpriced computer… who’s system got subsequently worse and worse with every new “idea” they introduced… sorry for the ranting. the only real solution is to wipe your system off and install new without the last update. thats what i had to do with another older computer and will have to do with this one sooner or later.


#3

Seriously??? WTH Apple!


(Pascal Golay) #4

Hi Izabela -
Does this have drivers that you can update or re-install?

-Pascal


#5

yes if wacom pulls along with a new update its all good, which in my case canon printer did not happen in 4 month… printer is about 1.5 years old so not very old… but that happened often with this printer each new update from apple the printer got bricked again like a cat and mouse game, this time the canon support said they may not update anymore for an older system… hr hr hr

but reinstalling will not help in anyway, if it really happened after the security update only the update from wacom would do.


#6

I installed the latest driver.
Maybe I’ll delete it and re-do it?
I also noticed that Photoshop has the same issues.

UPDATE: I contacted wacom… we’ll see what they say.


#7

there is a software which is called AppCleaner it deletes all connected files through drag and drop its very easy. just be sure nothing is running or include protected running files in the set up and also include all plist files. but i think it will not help much, so i hope for you that wacom reacts on this.


#8

HI.
I used Wacom with Rhinoceros over the past three years. I stopped using Wacom about 3 weeks ago. Because of my English I will be concise: Wacom drivers are incompatible with Rhino (Mavericks ,Yosemite, El Capitan, Sierra), causing blocks, slowdowns, crashes. Stop using Wacom with Rhinoceros. Fortunately it is not necessary to remove the driver. Simply disconnect the tablet from your Mac and use other tracking systems (I use SpaceMouse Pro (3Dconnexion) and three weeks Logitech logitech anywhere mx 2.
Three years of hell! issues resolved

Simon


#11

you can also use AppCleaner to restore an app to it’s default install state. pretty handy.