Navigation Issues with Wacom Tablet & Rhino 6

Sorry to open another post, but none of the existing one had a solution.
Since upgrading to V6 I can’t navigate the scene with my tablet (Intous Pro) anymore.
The setup was rightclick on the stylus button and navigate with shift, space & cmd.
This works in about any fourth try, most of the time nothing happens.
It’s very annoying as I used to work on tablet and now had to switch to mousse.
Anybody faces similar issues and found a solution?

(Rhino 6, MacOS 10.14.6)

Yes!!! I’ve had this same issue ever since the last update to Rhino 6 for Mac. I’ve tried to troubleshoot this but no luck so far.

Rhino Version 6 (6.19.19298.01152, 2019-10-25)
MacOS Catalina 10.15.1

I haven’t had an issue using Rhino 6 on Mac 10.14.6 I am using the Wacom driver from August here…

Did you ever have a Rhino 6 that worked with your tablet? Or was it just working with Rhino 5 on Mac? I’ve heard of this now from a few users but so far I can’t reproduce the issue. I wonder if it is a Wacom setting or driver issue.

I had no issues with V5, but never a working system with V6.
I’ve been in touch with the Wacom support, and resetting the settings was one suggested solution.
It had a bit of an impact which raised successful rightclicks from about 20% to about 60% - so basically still unusable.

I avoid updating the driver as I had a lot of problems by doing so,
and reverted to an older driver as suggested by the wacom support
(It’s a painfully manual operation doing this why I want to avoid giving it a try if a newer driver works,
also Wacom support says it’s not that likely that it would help if the older driver works better)

The tablet works for most applications the only issues I’m having is Rhino 6 & Affinity Photo

Support suggested to create a new (Mqac) user which solves the problem,
however that’s not a solution yet

I’ve been having a the same navigation problem with the Wacom Intous Pro tablet and Rhino 6 for mac os v10.14.6. It’s mostly the shift right click drag for Pan that has been giving me and issue by not functioning.

Same for me, Viewport navigation with right click is the issue.
Something you need constantly and makes it impossible to work with Rhino & Wacom at the moment.
I was thinking of downgrading to V5 for that reason.
Can we hope for a solution in the near future?
Maybe having it work by creating a new mac user might lead to a solution?

Same for me, even click from pen work differently :frowning: And in other computer from uni it works perfectly on Rhino 6, windows 10, and on my own better computer with the same windows 10 and rhino 6 it doesn’t work. and I also don’t work with mouse at all… don’t know what to do…

This topic was specifically about users of Wacom tablets that were having issues in Rhino 6 for Mac. It sounds like you are reporting an issue in Rhino 6 for Windows on a specific computer. If that’s the case, check that the Wacom driver and settings are the same on both the Rhino 6 for Windows that works and the Rhino 6 for Windows that doesn’t. At a guess, you may need to disable Windows Ink in the Wacom settings.

1 Like

Thank you very much! yeah it’s what I did first :). but now problem is resolved. I always specify in wacom what programs I gonna use. But then I decided to delite Rhino from the programs I’m going to use with wacom and it resolved the problem…:slight_smile: :slight_smile: