Solid out of border rhino

Hi there!

I’ve been having a problem with extrude curve in cases of large curve with arcs.
the solid looks like it is out of the borders.

Thank you so much!


Hey¡ Have u tried to change the way the meshes are display in your project? Go to options_doc-properties_mesh and change it to smooth and slower

i add an image

yes, it does not make a difference

any way it is a solid not a mesh…

yeap, but the display of nurbs in rhino is done with meshes…is really weird, could you attach the rhino file? maybe a problem with tolerances of the file…

Several options:
Scale your objects down by 0.01 or less
Move them as close to origin point as possible
Copy objects to new file
And Javier option is also good.

I uploaded the file here, you can see the tolerances does not make a difference, only if I split the curve to smaller curves.

I only see the image @11170

Where was the file uploaded? It does not appear in you post.

You can upload a .3dm file using the vertical arrow above where you type your post, or by dragging it to where you type.

exp to send.3dm (497.3 KB)

It is a display mesh problem. To display surfaces Rhino creates a mesh from the geometry and uses that mesh as the input to the display. The display mesh settings can be adjusted in DocumentProperties > Mesh. Frequently changing the setting from “Jagged and faster” so “Smoother and slower” will fix problems such as you are seeing. However in this case a “Custom” setting is needed, such as maximum distance from edge set to 0.1.

However for some reason the extrusion surfaces are not responding to changes in the display mesh settings. A workaround is to convert the extrusions to polysurfaces using ConvertExtrusion or Explode. Then change the display mesh settings. The only disadvantage to converting extrusions to polysurfaces may be an increase in storage size for a complex model with many extrusions.

I found if you use the setting @davidcockey suggests just moving the extrusion makes it update so something odd going on. So if you set the custom mesh setting move just the extrusion then snap it back to the curve it looks good.


Looks like a bug for updating display meshes for extrusions.

For me it was enough to scale in proper scale and move to origin:

Nevertheless it is annoying issue especially if you are working on renders… As you would not always like to scale or move stuff or even convert nurbs to meshes (especially in large scene with lots of objects) for correct renders as you already have set up correct render angles.

That is by design - see this thread

Yes, for “mere mortals” - the large majority of users who do need the special characteristics of extrusion objects and therefore have no reason to use them - I suggest turning off their creation “permanently” by running _UseExtrusions and setting the output to Polysurfaces. Then extrusions will not be produced anymore and meshing will behave as expected.

Even after converting the posted object to a polysurface, I find you still need a custom mesh setting to get it to look right. My “standard” settings for this size object are as follows…

You can also have a look at this page for more info about meshes.

The problem here is different than the behavior described in that thread. The problem here is the mesh divisions along the extrusion curve not refreshing, not the mesh divisions in the extrusion direction. The problem in the linked thread does not affect the display, unlike the problem here. This one is a bug.

It solved the problem

thanks for your help

Hi Mitch, I don’t think this counts as the same thing - I think the simplification of the mesh for lightweight extrusions is in the extrusion direction only, or should be - tessellation of the curves should be paying attention to the settings - this example looks buggy to me…