Meshing (Mesh or Export) from extrusion objects is wrong

Easy test -

  • Set UseExtrusions to Extrusions, make a box (extrusion) bigger than, say, 20 units
  • Copy the extrusion to one side, Explode/Join to make it into a polysurface.
  • Run the Mesh command on both boxes with the following parameters:
    (set a max edge length of something smaller than the box, say 10)


The mesh made from polysurface box will obey the max edge length setting, the one from the extrusion won’t. This is particularly pernicious as it also affects all export formats(such as STL) that export meshes directly, you will not see the problem.

Hi Mitch - yeah… I’ve moaned about this before, though I admit I cannot find a YT item at the moment - maybe I just tackled Dale Lear in the corridor. Extrusions seem to ignore any subdivisions, so to speak, in the extrusion direction- you only ever get one poly in that direction, the sort of built in fast and lightweight mesh that extrusions make…


Presumably this should not matter in many cases but of course sometimes it does. In your case, is it the discrepancy between the setting and the output that irks or is there a practical reason why this is a problem, like exporting for fea or some other process that needs the internal polys?


It is both, with an emphasis on the first. I do not like it when Rhino “thinks it knows better” and does not give you what you asked for in settings.

If you go to the trouble of creating custom settings for mesh creation or export, Rhino should just accept them and produce what is asked for, no matter what the reason the user might have for creating the settings in the first place.

Who knows what the user will do with the mesh object after? Maybe they want to do some point editing on the mesh afterwards, use it in a downstream program that needs more or less regular shaped polygons, or maybe just for appearance purposes? It doesn’t matter, Rhino should give the user what they ask for (if possible) and not just silently fail to do so.