Solid hatches become boxes instead fitting into form

Hey there!

In my latest project I experiences some problems with solid hatches. If I create solid hatches in smooth forms (in my case hatching green fields within a urban park) some of them don’t fill the form - instead they became boxes. Some thing I noticed: Sometimes when I move those hatches just to another place they turn into their real form. But I can’t move my whole drawing because of this. In some cases I selected the hatch and then - dupborder - hatch them and the problem is gone. In other cases they still appear wrong. If I use other not solid hatches with a very small size, I can “optically” avoid this but when I go printing I get not really good looking prints.

Does anybody know what causes this?

Here are some pictures:

Hi - please post a 3dm file with that hatch. Also run the Rhino SystemInfo command and post the result here.

Rhino 7 SR0 2019-6-25 (Rhino WIP, 7.0.19176.14015, Git hash:master @ ab0a4a8838bfdaea1f5904fcae479b81e5bddaac)
License type: Studentenlizenz, build 2019-06-25
License details: Cloud Zoo. In use by: mexdus ()
Expires on: 2019-08-09

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: MS-PC

Non-hybrid graphics.
Primary display and OpenGL: Radeon ™ RX 480 Graphics (AMD) Memory: 8GB, Driver date: 12-17-2018 (M-D-Y). OpenGL Ver: 4.6.13543 Compatibility Profile Context 25.20.15003.5010

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 12-17-2018
Driver Version: 25.20.15003.5010
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 7.0.19176.14015
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.19176.14015
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.19176.14015
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.19176.14015
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.19176.14015
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

Error.3dm (8.4 MB)

Your file may be too far from the 0,0 coordinate origin.

Hmm. Maybe - but why all other hatches work correctly? I see that only hatches get weird, when their curvature is very “fluid”. Regular hatches - I mean with simple geometry - work as designed. This problem also appears still, when I move the hatch to 0,0,0.

The reason why the whole drawing is so far away from zero is that the file is geo-referenced.

Here you can see the three corrupted hatches (stadium, above and left to the lake).

Hello - Run SimplifyCrv on these curves, and then Hatch


That’s the fix! Thank you so much!