Solid hatch doesn't print


I’m trying to print a drawing, and for some reasons some solid hatch patterns doesn’t show up when I do. I’ve tried:

  • changing hatch scale (and disabling hatch scaling)
  • checked all layers both in layout and model (the problem happens in both layout and model view)

I have the same results if I try vector or raster output, and the same on different printers and pdf printers.


Hei Oskar - trying here with a similar scene, and the RhinoPDF printer, everything seems to be working as expected. Could you both share the scene you are working on (simplified to include only those items that are needed to reproduce the issue) and run the Rhino SystemInfo command and post the results here?

Hi again, thanks for replying so quickly!

How do I share a scene? If i try exporting the things im working on the draw orders change and I dont get the viewports exported, so everything is different.

There also seems to be a general problem with draw order in the file as the bringtofront and sendtoback are being very quirky and giving different results every time. (I’m not using blocks btw)

The file is 40+ mb so seems to big to upload.


Rhino 6 SR8 2018-7-24 (Rhino 6, 6.8.18205.11111, Git hash:master @ 779a99ec30d2785f0f638420cc3ab52d5a268459)
Licence type: Educational Lab License, build 2018-07-24
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: SB1-5103B-14

GeForce GTX 1050 Ti/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 390.77)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-23-2018
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.8.18205.11111
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.8.18205.11111
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.8.18205.11111
C:\Program Files\Rhino 6\Plug-ins\export_PDF.rhp “PDF Export” 6.8.18205.11111
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.8.18205.11111
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.8.18205.11111
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi - the easiest would probably be to make a copy of the file and to delete everything that is not needed in the copy.

Rhino 6 SR8 2018-7-24 (Rhino 6, 6.8.18205.11111, 2018-07-24)

Please update to the current Service Release, which is SR13. I would try that first - Rhino 6.8 is a long time ago, and there have been fixes in this area if I’m not mistaken.


Sadly I can’t update as I’m on a school computer and they do everything centrally.

apartment_nr2_6_copy.3dm (9.4 MB)

Hello Oskar

I have checked your attach and seems all is good,
I have last update version, the issue might it be as Wim Dekeyser said.

apartment_nr2_6_copy.pdf (1.2 MB)

Many thanks

Oh what timing. My home computer just broke so I guess I’m stuck with this version :sob:

I would try to get someone at the university to update the installation.

A quick-ish work-around would be to select these white hatches, extract their borders (DupBorder), and then use these new curves to trim the curves that should be under the hatch.

Yes this will be what I’ll do in the end, it’s just that I change the objects and placement overtime and have to redo the process several times. But it will definitely work for the final.


OK, in that case, I would probably do it the other way around.
For example, make a rectangle (that represents the living room). Then make a few rectangles that represent a table and chairs. Select all, turn on History, and then run Hatch. Pick a pattern that represents the floor boards.

When you need to change the placement of the table and chairs, select the curves for these and move them - the hatch will update automatically:

Oh that’s a really good idea, ill try that.