Rhino 5 hatch printing problem

Hi there,

Here’s my problem:

I have a file with both 3d and 2d Drawings in Rhino 5. When creating a New Layout (for the 2D drawings) sometimes some of the hatches do not show, sometimes none of them appear. Also the printed PDF does not show the hatches if they don’t appear in Layout Display.

I am using Rhinoceros Version 5 SR14 64-bit (5.14.522.8390, 22.05.2017) on Windows 10

  • My PDF Printer is Adobe PDF
  • Enabling/Disabling Hatch Scaling does not change anything
  • Changing the model space hatch scale does not do anything either
  • I had this problem with several files already so creating a new file does not help.

Also, when I open and print the file on one of my colleages computers the hatches show and print perfectly…

Does anyone know a solution for this? Or is this a bug?

Hi Lisa - what is the video card on your machine and what is the driver date? (Options > View > OpenGL page)


Hi Pascal!

Here’s the details:



Hi Lisa, the GPU and driver seem fine.
Do you see the hatches in the model space and it is only in the layout that you don’t see them?
@jeff, any ideas as to why hatches wouldn’t show in a layout?

yes, the hatches seem fine in the model space - it’s only in the layout that they don’t show

Hi @lisa.brunner93,

Is this easily reproducible? If I create a hatch, then create a Layout, I can easily see the hatch… so obviously I’m not doing something you are…

In these types of cases, it’s always a good idea to provide an example 3dm file so that we’re all not trying to guess at how to duplicate what it is you’re seeing.

So, if you have an example that shows the problem, and you can release it publicly, then please post it…if it’s a confidential file, then there are other ways to get it to McNeel… But I would first try to come up with a simple example where a hatch or hatches don’t show up in Layout space…and then confirm it happens all the time… (i.e. Close Rhino, start Rhino, load the file, confirm the problem exists, …repeat that process 5 times)… Then post it here.

Am I also understanding correctly that the same file(s) load and display correctly on other (colleague’s) computers? If so, then this could be something as simple as a configuration setting on your system. It also may have something to do with how you’ve setup and positioned your detail views…which is another reason why getting an example to us would be helpful.

As of right now, I do not know what would be specifically limiting hatches in Layouts…if you can see the same hatches in model views, and they display and act correctly in all situations, then obviously this isn’t a video card or video card driver issue, and is most likely a bug in Rhino that you’re able to uncover and we’re not…so we need to just keep digging more, and collecting as much information from you as possible.


Oh wait… I just realized that you’re using Rhino V5… Unfortunately, if this is a bug in Rhino, it’s not going to be fixed in V5 since there will be no more service releases for that product.

Given that, I would be very interested in hearing if you’re seeing the same problem in V6.


Hi Jeff!

Here’s a test file where I cut out something of one of my problematic files. (obviously I can’t send the whole thing as it is for work)

What I just realised now and somehow never discovered before - this has probably to do with the wireframe mode - when I switch to wireframe in the model view (as it is in the layout) the same problem appears also in the model.

This is one of the files where just some of the hatches don’t show. (the solid hatch shadows bottom left and bottom right and all the pattern hatches I added). I also had a file recently where none of the hatches showed (all solid hatches).

As I said, this works just fine on my colleage’s computers.

test file hatch problem.3dm (4.6 MB)

I would be happy to tell you if I am experiencing the same problem in Rhino 6, but unfortunately I don’t have it yet.

Thanks for your help

Hi Lisa, It sounds like you might not have a factory-default Wireframe display mode. When you check Rhino Options > View > Display Modes, does your Wireframe mode appear in blue text like in the following image?

With the Wireframe mode selected, press the Restore Defaults button at the bottom of the dialog box. Does that do the trick?

yes, it worked - thanks!