Snapping very incosistent and unreliable in V6.3

osnap

(Gustavo Fontana) #1

Hi RMA team, I’m running Version 6 (6.3.18090.471, 03/31/18) and I continue to experience very weak, sometimes not even working snapping. Mostly happening at end Osnap but maybe that’s because that’s what I use the most. Are you aware of this problem?


(Pascal Golay) #2

Hi Gustavo - I have seen, a couple of times only so far, that snaps appear to stop working under some (unknown) conditions but I have been unable to save a file in that state or reproduce the problem once it sorts itself out. If you have any repeatable way to get in this state, shout.

Also, just in case, there is a setting in V6 that was not in V5 for ‘Snap to occluded objects’.
That could mess you up…

-Pascal


(Gustavo Fontana) #3

Hi Pascal,

I’ll take a look at that setting and watch for problem files. Thx.


#4

The END osnap is buggy for us too, usually when there are leaders in the file.

Dan


(Pascal Golay) #5

Hi Dan - so I guess that was not fully fixed with

https://mcneel.myjetbrains.com/youtrack/issue/RH-44631

(6.4)

?

Or is that a completely different thing? In my case, mentioned above, it’s unlikely there were leaders.

-Pascal


#6

Hi Pascal,

I haven’t looked at 6.4 yet. I’ll load it on my laptop tomorrow and check it out.

Thanks,

Dan


#7

Hi Pascal,

Yup, looks fixed in 6.4.

Thanks,

Dan


(Pascal Golay) #8

Excellent, thanks for letting me know.

-Pascal


#9

Osnap (End in particular) is buggy for me when SmartTrack is on.


(Tom D.) #10

Noticing that OSNAP is buggy for me also, and I’m running 6.4… I tried turning off SmartTrack but it made no difference.

Here is a quick screen capture of the problem. Perhaps that will help? It looks to me like there is some depth filtering going on. Note that the blue curve was projected on to the surface, and in the past there was no issue with End OSNAP.

Osnap Problem

Cheers!

Tom


(Pascal Golay) #11

Hi Tom - Check Options > Modeling aids page, Object snaps area > Snap to occluded. That is new in V6 and if off, will mess with curves on surfaces in shaded modes due to the shading meshes being off the surface. Make sure that is checked to restore V5 behavior… Any luck?

-Pascal


(Tom D.) #12

Hi Pascal,

Thanks for the tip; it all works now. Its the change of behavior that threw me, and I didn’t think to go hunting for a setting.

It is a bit strange to me that a line, projected on to a zero-thickness surface, would be occluded but on a concave surface I get that the rendering mesh would necessarily be inside the actual surface, so in front of the line…!

Cheers,

Tom