Osnap and Snapping issues

Is anyone else having issues with simple snapping and Osnap in Rhino 6? Working fine in Wireframe and Ghosted, and Xray but “wonky” in shaded mode

Rhino 6 SR2 2018-3-6 (Rhino 6, 6.2.18065.11031, Git hash:master @ cd4fa1dcdec31cb58baacef0855771173af7196f)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Quadro K5200/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 391.03)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-27-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Hi Tommy - see if the setting on Options > Modeling Aids > ‘Snap to occluded objects’ makes a difference here.


1 Like

Pascal - Ah! Problem solved, thanks again sir.

more coffee will be consumed before my next posting haha


No worries - there is plenty of new stuff, and a glitch or two as well … that’s why we have the forum.


A post was split to a new topic: Getting started with Mac Rhino

I solved by pressing “reset default” on settings window from right click on Osnap in the bar below.
I think my problem was the “check” on osnap only if object was selected.
Maybe it could be useful for any others

Users generally turn that option on when they find they are unintentionally move objects. It then requires 2 clicks to drag an objects; one to select, and second to drag.