Snap to Occluded Objects Still Broken

Was in issue in Rhino 8 Beta and still is an issue in Rhino 8 Commercial. When using distance, move, scale 1d, tab, etc etc, cursor trys to snap to occluded objects despite the option being toggled off.

Hi Brady - I am not finding this to be true here - can you post an example?

-Pascal

Hi Brady - can you please run the SnapToOccluded command as you do this and see what it says at the command line?

-Pascal

It says to enable, disable, toggle. I selected disable to no effect.

Hi Brady - when you run the command, what does it say the current state is?

image

Does this happen in any file, even a new onw with a box or plane occluding some curves?

-Pascal

It says the current state is DISABLED. Been happening in every file for over a year. It doesn’t happen if I just draw a simple cube with a curve behind it. It takes a pile of occluded geometry to confuse the snaps

Hi Brady - can you please post or upload a file that breaks this to Rhino - Upload to Support, to my attention?

-Pascal

done!

Hi Brady - thanks, got it - in the view as the file opens, it works, here, as expected in Shaded but shows the problem you describe in Rendered views… still poking.

RH-78334 SnapToOccluded and Rendered display

-Pascal

1 Like

Thanks Pascal

Hi Brady - the culprit in Rendered modes is the ground plane - if that is on, the depth testing is messed up - it will be fixed in 8.2, but in the meantime, turning off the ground plane should sort it out.
Thanks for the report.

-Pascal

Hmmm. Just tried turning off the ground plane in rendered mode but it didn’t fix anything. In fact, the modified rendered display mode I use the most never had the ground plane turned on in the first place.

Hi Brady - m… in your file, here, the GP setting exactly corresponds to the snap problem… I wonder what else is going on - can you please export the display mode you use and post it here?

Also, @brady1 - please try toggling the GP from the GP panel and not in the display mode settings…

-Pascal

Here is the display mode I use the most, but the issue was also happening in normal rendered mode even after turning the ground plane off

Paper Space Display.ini (14.0 KB)

@pascal any updates on this?

Hi Brady - this should be fixed - I believe you can now get the SR2 service candidate release via Options > Updates and Statistics page, setting the update frequency to Service Release Candidate. And Update Now.

-Pascal

Hi Pascal,

Just downloaded SR2 and the problem still persists. Screen recording and system info posted below.

Rhino 8 SR2 2023-11-21 (Rhino 8, 8.2.23325.14001, Git hash:master @ f6e34187305c277ac44e974b0555f3daf930d719)
License type: Commercial, build 2023-11-21
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 64Gb)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA RTX A4000 (NVidia) Memory: 16GB, Driver date: 10-18-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 537.70
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-18-2023
Driver Version: 31.0.15.3770
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16376 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

@pascal any updates on this or if I am the only one still having the problem?

hi @brady1 I recall you had issues with this before but that this eventually was solved, I just checked that file again and that is still working as expected ( RH-72252 OSnap: Snap To Occluded did not work in some cases).

I just downloaded your new model and can confirm that it is indeed not working as expected here either. I will dig some more tomorrow in that model to see if I can find the cause.