R8 - Snap To Occluded Objects - Can't turn off


R7 user trying R8 the past couple days and, as is, it’s unusable. Under ‘Options > Modeling Aids’ un-selecting ‘Snap to occluded objects’ makes no change. The cursor shouldn’t try to snap to a thousand things in the distance behind a shaded surface. It’s impossible to be certain I’m not accidentally clicking something in the background, or the wrong edge of a thin extrusion, etc. This was occasionally a problem in previous versions but now it’s full-tilt.

Is there some other setting or switch for this? There’s no way I’m upgrading our company to this… it’s an accident waiting to happen unless solved.

There’s several other issued I’ve discovered in R8 but one thing at a time. Thanks for any help.