Smoothing joined surfaces

Hi all,

Please find a screen shot of the object I am trying to surface and a file containing 2 of the sections.

I am getting a visible seam line between the surfaces and was wondering if it was possible to smooth them to give a seamless look. I have tried mergesrf and blend but nothing seems to help.

Any suggestions?

TestRhino_v5_65 copy.3dm (2.6 MB)

it would be more helpful to post the all the input curves instead. i am sure you can mold that out with one surface, so probably there is something with those curves.

its not clear how you build that lofty surface, but if you take the 2 short profiles curves and use match set to curvature you can check merge, you will then have a continuous surface when sweeping.

1 Like

TestRhino_v5_65 copy 2.3dm (5.1 MB)

The full file was too big so here’s a qauter of it, its all symmetrical so hope this is of use.


why are you separating the orange curve? that should be one continuous curve. since they are g2 continuous i assume you have split that at some point. if not you can merge them all together bit by bit with the command match.

I split the orange curve to run sweeps to see if that worked, I have tried merge but this still leaves a ridge, it’s better but not quite right.

if you have the orange one continuous and the upper small hole also, then all those profile curves rotating around could be used as input curves for sweep. i am sure it will be a continuous surface then. otherwise you might have a little dent somewhere. that file should also be pretty small when you export it. maybe purge the file, select the initial curves and export selected with option geometry only and save small.

oh wow wait now i see, all those curves around the circles have an extreme high amount of points. use RebuildCrvNonUniform. that should bring you there. then sweep again.

Many thanks, just tried as you suggested but still odd results.

your curves are incredibly dense
I don’t know if this is really useful for you or not
anyway i simplified them using the fit command
and then I executed the loft command with the loose option.
this allowed to have a smooth surface


That worked nicely, but, it seems the resulting surface doesn’t follow the lines, the distance from curve to surface is 1.5mm ish.

Your curves are too dense and do not represent a clean quarter.
You should provide the full orange curve and if the top isn’t a proper circle then also the top.

follow the steps of this video