Small bug: ground plane settings are being lost

There is a small bug occurring in V6/V7 Mac as well as in Windows (I believe):

Steps to reproduce:

  1. activate Rendered View
  2. go to ground-plane settings and set them to shadows only
  3. insert a block
  4. close and open the file again
  5. result: ground plane is there again

Not a huge bug, but a bit annoying…

Cheers, Rudi

I am unable to repeat that in V7 Mac or Windows.

Normally the Ground Plane in Rendered display mode follows the current Render settings.
Have you diddled the settings in Rendered?

I tested this with pure default settings.

The must be more to this puzzle than you have reported so far.

What tool are you using to turn off the Ground Plane?
I’m using the Ground Plane in the Inspector panels.

Interesting… I can even reproduce this bug with importing a simple box.

I applied the Reset To Defaults in the Rendering panel and also applied the ground plane settings there as can be seen in the screenshot attached.

system_info.txt (9.4 KB)

Did you save the file after the change to shadows only? I think so but the video was too low res to see. I haven’t been able to reproduce this either yet here but will try again.

Do you have multiple Rhino’s open too? This hasn’t caused it to happen here but just checking.

Hey Brian,
I saved the file after making the change and closed it then. Also had only one Rhino opened.
Hope this helps :pray:

Thanks, I tried the same but can’t reproduce what you showed. I wonder if it has to do with any specific block or Plist setting (your Rhino for Mac preferences file). Have you tried resetting the Plist? You can make a copy of it first so that you can replace it again if it doesn’t make a difference. Here’s the info on how to find and reset your Plist file.

If you can post the actual block you Insert as well, I can try that too. Thanks.

Hey @BrianJ, excuse my very late response…

I tried the steps mentioned above, but issue is still here. Furthermore, after resetting the Render settings Rhino freezes every single time (after 10-20 seconds).

Here are some steps to reproduce this issue, took me some time to distill it to its minimum:

  1. Open a RH file with two boxes (ground plane settings will probably be lost = white ground):
    Model.3dm (3.0 MB)

  2. where other two boxes are inserted as a Block:
    Block.3dm (2.8 MB)

  3. Make sure the background is set to Application settings in Rendered Preview:
    Bildschirmfoto 2021-05-13 um 20.46.04

  4. reset Render settings:
    Bildschirmfoto 2021-05-13 um 20.45.54

  5. wait 10-20 seconds. The application will freeze.

Hope this clarifies this bug!

Thanks a lot,