Slow File Open And Save To Server

My office is experiencing very slow file open and file save operations when opening or saving files to our office server. Opening or saving the same file locally to our workstations takes a fraction of the time. 9 second file save to local vs 9+ minute file save to server.

I have read through the numerous other threads on the forum describing similar issues and have tried a variety of solutions but nothing has helped. (Change SetArchiveMemoryBufferSize, Turn off/on file compression, turn on Rhino.Options.FileSettings.WriteLocalTempFileWhenSaving, Disable VMQ on server, etc.)

The above referenced times are for a test file I created that is large but basic. The file is an array of ~260,000 spheres (no materials) that creates a roughly 727mb file. This is of course a very large file but the problem is also present on actual project files that are much smaller, say 150mb. Our office has regularly worked with Rhino files in the 500mb to 1.5Gb file size for years and have not had significant issues. I am not certain exactly when the issue began for us but I think it was around the time we upgraded our server (a few months back). Having replaced a 10+ year old server, the new server should be better in every way at least in terms of performance specs. But I suspect there is perhaps some issue between Rhino and our server. If I copy the same Rhino file directly to the server the file is transferred almost instantaneously.

A little bit of additional info about the behavior that I have not specifically seen described in the other related threads. When I hit save and immediately check the network activity in task manager, I see a spike in send network activity peaking at roughly 950mb/s. That holds steady for about 10 seconds or so and then send activity drops to 0 mb/s and then occasionally fluctuates up to ~40 mb/s before dropping back to 0 mb/s and then repeats but mainly staying at 0 mb/s. After the first 15 seconds the file appears to have been completely saved, at least in terms of file size seen on the server. The file size on the server at that point is the final file size but back in Rhino the save operation is still ongoing. I cant help but think that first 15 seconds is the actual time it is taking to save the file and then something else is happening. In this example, the save operation continues for another ~9 minutes with seemingly nothing happening(or I should say I just don’t know what is happening). Then after 9 minutes the save completes in Rhino, but the file time for the newly saved file on the server does not change from the time the file was created 9 minutes prior. Perhaps this is normal activity, but I just wonder what is happening in that long period after the file has been created on the server and Rhino completes the save operation.

Any help would be much appreciated, this is really killing our workflow.

Do you have any third party plugins installed?

VRay and Enscape but both were disabled at time of testing.

Hi Chris -
Please run the Rhino SystemInfo command and copy-paste the result here.

Hi Chris,

If you take one of the files that you copied to your PC and use file manager to rename it to test[something].3dm and, again in file manager, copy it to the folder on the server where you normally save your Rhino files does that take about as long as saving it from Rhino or is it pretty instantaneous?


Here you go. Will get back to you Jeremy.

Rhino 7 SR21 2022-7-27 (Rhino 7, 7.21.22208.13001, Git hash:master @ c31aea87137a5d0de449338a7ef6856f49dd4797)
License type: Commercial, build 2022-07-27
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 7-21-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 516.94
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-21-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi Jeremy, its instantaneous to copy file to server.

Thanks, Chris.
I see that, in your first post, you wrote:

turn on Rhino.Options.FileSettings.WriteLocalTempFileWhenSaving

That setting was changed to default to True in 7.21. What happens when you turn that to False?

That likely rules out networking or server issues. One for the McNeel backroom boys to resolve…

Hi Wim. OK, tried changing the WriteLocalTempFileWhenSaving, here are my results. I did notice unique behavior in each condition. FYI, I made a smaller test file so numbers wont match times in first post.

WriteLocalTempFileWhenSaving = True
Save time (two tests) = 3m30s / 3m38s

  • When setting is set to True, the behavior is consistent with what I described in my original post. Short period of high network activity (950mb/s) followed by long period of minimal network activity (fluctuation between 0 mb/s and 40 mb/s) for remaining minutes. File size on server is full size within 10 seconds of save.

WriteLocalTempFileWhenSaving = False
Save time = (two tests) = 4m30s / 3m50s

  • When setting is set to False, the behavior is slightly different. Consistent ~50mb/s for the first minute of file save before file reaches full size on server. A temp file is visible while this is happening. Followed by 3 minutes where behavior is the same as above (fluctuation between 0 mb/s and 40 mb/s).

Let me know what you make of it.

The setting does appear to make a difference, but file saves to server are still orders of magnitude longer than local drive saves.

Hi Wim. Any thoughts on the results of the test?

Hi Chris -

Not really. Just to make sure, have you tried reverting to 7.20 to see if that makes a difference?

Yea, the issue was present prior to this release, I had just not had time to report issue. Is the behavior I describe in my previous post normal? Hoping for some help, this is really slowing down our workflow. And we dont know what to tell our IT company as other programs/tests dont show the same issue. Not sure what mix is causing the issue.

Hi Chris -

No, not at all. That’s not something that we’ve seen before and only has people scratching their heads around here.

I suppose we could try to eliminate (or not) Rhino from the picture by at least going back to a Rhino version that you were running before the server upgrade. That Rhino version worked fine for you at that point - if that same Rhino version no longer works fine now, it sounds like it a server thing. If that same Rhino version still works fine, we’ll have to try to narrow down which exact version of Rhino went wrong in your environment. Or?
How often do you update the Rhino version, and when was the server upgraded?

A similar post recently.