ShowOsnap is switching to Off by itself

unhandled

#1

ShowOsnap is always off when starting rhino, even though I always keep it on.


Cloud Zoo License Management Available in Rhino 6
#2

Yep, known bug, don’t know if it’s going to get fixed for the first release version either…


(Pascal Golay) #3

Hi Bogdan - does this happen every time you start or only after an update?

https://mcneel.myjetbrains.com/youtrack/issue/RH-43515

-Pascal


#4

In my case, every time the Beta/RC is started. --Mitch


#5

Even I find the same problem.
First access to Rhino: Onsnap does not appear automatically.


You have to click on “Onsnap” to bring up the bar


#6

Hi pascal,
It happens every time.


(David Cockey) #7

Same for me.


(Pascal Golay) #8

Hi all - just as a test, can someone please try setting

Options > Advanced page >
Rhino.Options.Advanvced.ShowObjectSnapDialog to True

and then close Options and then close and reopen Rhino. Shot in the dark, and not a real overall solution, but I am curious to know if that setting sticks if you set it explicitly in Options.

-Pascal


(David Cockey) #9

I can not find Rhino.Options.Advanvced.ShowObjectSnapDialog in Options > Advanced
Perhaps I’m overlooking it. Where should it be in the list?
BETA
(6.0.18012.13241, 1/12/2018)


(David Cockey) #10

It is Rhino.Options.Appearance.ShowObjectSnapDialog

Set it to True, closed Rhino, opened Rhino and the OSnap bar was visible.


(foreigner) #11

Here it is …


(Pascal Golay) #12

Hello - so, is yours set to True and OSnaps still do not show when you close and re-open Rhino, or? What is the behavior of the OSnap toolbar if this is set to True?

-Pascal


(Pascal Golay) #13

Hi David - thanks - I think that supports the idea that it’s a flaw in how Settings is being handled. Looks like a 6.1 item for now. Hopefully the Options setting is an OK workaround for users who encounter this in 6.0.

-Pascal


(David Cockey) #14

Pascal - The OSnaps bar now is showing when I open Rhino, even when I opened a file saved last night which has Rhino.Options.Appearance.ShowObjectSnapDialog as False in Options > Direct.


(Pascal Golay) #15

Hi David - that should not depend on the file opened- it is a application level setting - so, if I am thinking about this right, you should be all set… but we shall see, it may be that the opposite problem will occur - it won’t stay closed - if we’re not writing that settings file correctly.

-Pascal


(Brian Gillespie) #16

I was just able to reproduce this problem. See my comment in RH-43515 and let me know if this is consistent with what you’re seeing.


(Pascal Golay) #17

Yep, that sequence shows the problem here.

-Pascal


#18

this worked for me, thanks.


#19

In my case the Rhino.Options.Advanvced.ShowObjectSnapDialog resets itself to False every time I open Rhino V6 (not just after an update).

–Mitch


#20

Same in my case. It resets to false, plus shifts location as I’ve mentioned in other posts.

Dan