Shortest List Within Each Branch?


I have two groups of three curves. These curves have all different lengths. I divide them. And so I end up with different number of points in each curve.

I want to perform a shortest list withing each group. So that the poly lines I create always have three points.

Tree (6.5 KB)

Thanks for any help!

Interesting problem. Do-able, but clearly some hoop-jumping required.

Tree (22.1 KB)

1 Like


Frustrating problem! Can it be done without ‘Path Mapper’ (twice!)? This sort of thing happens all the time. It would be so helpful if ‘Flip Matrix’ was “smarter” and flipped each “limb” of the tree, where each limb has three branches. This kind of thing shouldn’t be so hard.

P.S. This gets the lines but loses the grouping at the ‘PShift’ just before ‘Flip’. So close…

Tree (11.1 KB)

Tree Shortest_2017Nov23a2

This solution uses an Anemone loop to preserve “grouping” of the horizontal lines. Ridiculous? Absolutely. More so than two ‘Path Mappers’? That’s debatable. I don’t know if there are any advantages to either approach(?), other than this one is easier for me to comprehend.

Tree (25.3 KB)

the points aren’t here (though they could be if you show ControlPoints on the copied polylines)…
it finds the shortest line of each group then copies a polyline the appropriate amount of times for that distance.

Tree (12.4 KB)

Avoid trouble whenever possible - good idea. Doesn’t work with curves though.

By the way, I ran into a variation of this same “flip limbs” problem while adding a “data set” group. In the “bend” group, I want to use ‘Interpolate (IntCrv)’ instead of ‘Arc’ but don’t see a way to accomplish that while preserving the original tree/limb grouping of lines/curves?

Tree (33.2 KB)

Later… Got ‘IntCrv’ to work in “bend” group by grafting ‘Merge’ inputs and ‘PShift’ after (below):

Tree (36.7 KB)

Hi, I tried downloading some of the files posted here but all link take me to “not found”…

Also tried save link as and all def wont open. Try both Mozilla and Chrome. Is it just me?

Same for me on Safari. 404 not found