Shift+Cmd+RMB bug

Rotating the perspective view with the RMB and trying to lock it in to an orthogonal view by pressing Shift+Cmd doesn’t always seem to work here. It seems to be possible to lock it to a view that isn’t a true orthogonal view, but some sort of perspective view with a really long telephoto lens. It’s not always easy to detect that the projection is off. The view is also ‘jumping around’ sometimes when locking into a ortho view.
I noticed the problem when trying to project a curve on to a curved surface and got a strange result.
V6 doesn’t have the problem.

It would also be nice if the “One View” viewport labels (in the upper right corner of the viewport) would reflect the orthogonal projection - to confirm that it is a true orthogonal view.


Some more testing…

To get the correct orthogonal view you have to release all buttons at the exact same time. However there are still occasionally some hiccups… Trimming, for instance, in the orthogonal projection doesn’t always work - even if it works in a ‘normal’ ortho view(port).
When going back to perspective projection (by pressing shift + cmd + RMB again) the view also sometimes ‘jumps’ (= zooms out) unexpectedly.

To get the “false” orthogonal view: release shift + cmd before releasing the RMB.

Are you able to repeat this? @dan, @pascal

A wish: the CPlane should automatically be set to the correct corresponding projection - otherwise it’s, of course, impossible to draw in the viewport (when looking at the CPlane from the edge).
And the second wish:

Is this possible? I feel that without these two features the implementation is only halfway there. What do you think?


What is your rotation setting in the command line set to?

You mean for OneView? Default (10 degrees).



can you post a video of what you are seeing? I can’t reproduce your issue here-

Ok - here’s a simple screen recording.

I’m rotating the view normally (dragging RMB) and trying to lock the view with cmd + shift and releasing all buttons simultaneously. However - if I release the RMB a fraction too late I get this weird behaviour where the resulting view is not the normal, expected parallell projection, but a perspective view with a long lens (?). Trying to pan the view after that with the RMB moves the camera sideways (and up and down) in this strange, locked perspective view. Can you repeat that?

Releasing all buttons simultaneously at the exact same time results in a correct parallell projection, of course. I wish you wouldn’t have to be so precise to get the correct behaviour. It’s too easy to get a view that’s only a tiny bit off (not as much as in this exaggerated video) - that error can be difficult to catch in time.


I am not seeing that behavior here… in fact it snaps rather robustly into and out of the cplane and ortho views.

what I am doing:
rotate the model normally, as I’m getting close to ortho, I hold down cmd+shift. Rhino snaps rather strongly to the ortho view… then release cmd+shift.
work in ortho
hold down cmd+shift and rotate to pop out of ortho and back to perspective…
super reliable here…

are you using a mouse with cursor acceleration turned way up?

Action sequence in Win, perspective to orto:

  1. RMB
  2. Ctrl+Shift
    switches to an ortho
  3. Let go first RMB
  4. Ctrl+Shift
    can you in MAC too should be, try.

If you simultaneously let go of all the buttons then, not always, it turns out the same effect as you in the plot.

Yes… but did you try releasing the RMB after releasing Cmd + Shift? That’s how I get the odd long lens behaviour. I think it should just continue rotating the perspective view normally, if I release the RMB too late.

No - default acceleration here. I tried two different mice (Logitech and Apple) - same result.


Yeah, thanks, that works ok, but my point is that you shouldn’t get this strange behaviour even if you release the RMB too late - in that case dragging the RMB should just rotate the view normally.


Sorry for using wrong terms here… The lens length stays the same, but I can not rotate the camera around the model - only pan.


Looks like you’ve got a CMD button sticking on your computer.

Nope, that’s not it…