Shatter curves


Maybe somebody wants to help ;).

I create closed curves (38- 0,1,0,0) and find 2 Points/Params (76- 0,1,0,0) on each of the curves. When I try to Shatter curves at given Parameters, instead of two curves per “curve” (76) I get up to 15 segments/curves (15- 0,0,0,0,1, totally 2176). It looks like it depends on the curve geometry. With some curves it works, but not with all the curves, that is why I believe that it has nothing to do with Graft of Flatten ;).
What I am doing wrong?

What is also interesting that it works in one direction (the same input), but not in the another ;).

Without an attached gh that will be hard :wink:

Yup, hard to help without a GH file! First thing I’d check though is whether you are using the correct parameters i.e. are your parameters ‘correct’ within the curve domain? If you are trying to split at the mid point and are using a parameter of 0.5 to do that, you need to ensure your curve has a domain of 0-1. You can do that by reparameterising the curve.

Just speculation at this point though without a file to look over!

I used “Shift Paths” function and it looks like it is working a little bit strange- I found that if I do not use it (too often) then “Shatter” starts to work.
It looks like now I am getting the problem with “Brep/Plane” intersection. I choose 4 Breps and try to intersect with 19 planes each, but the result is 20 section for each Brep (4x20=80) instead of 19 (4x19=76). It was working so far, but what is the problem here I do not manage to find.

Can anybody try to explain what I am doing wrong? (39.4 KB)

After I saved the file everything looks ok. It looks like Grasshopper do not mange to update from time to time.

Is there any possibility to update the whole worksheet at once?

as in right click and recompute?

this is not always true, or better: mostly not true. If you feed 0.5 to shatter a reparametrized curve that has uneven distribution of control points, it will certainly not split in the middle of the length of the curve.

1 Like

Yeah it was a pretty lazy response on my part to be honest! I’ll go fix it up