ShapeDiver model denied - computation time limit

Hello, after uploading a model I’ve got a message:
“Your model model 3d 2.0 test took too long to compute on our servers. Your account is limited to 2 milliseconds of computation (the model took 3 milliseconds )”

It’s confusing since:

  1. my model computs in arround 100milliseconds
  2. ShapeDiver webpage informs me that i have 5 seconds (5000ms) of computation time

What are my actual limits?
Is it possible that the model was denied dew to other problems in the definition?

You get 5 seconds of computation time with a free account, see more details on our pricing page.

I’m not sure what went wrong with your upload, there could be other issues but it’s hard to tell from the error message. Try narrowing down the problem and share a minimal version of the definition replicating this so we can have a closer look.

These resources can help you with uploading to ShapeDiver.

Thak you for answer.
I’ve checked all the links that you’ve linked, double checked the file size, internalizing etc.
I don’t use any thirdparty plugins or clusters.
I attach GH file. I don’t know which part can cause problems, so i didnt minimalize it but I organized it. Please let me now if the definition is unclear.
Model was uploaded to shapediver from account: GabrielCzyz
Here is the link to the same model, but with all geometry fixed and internalized: just display 2.1 - ShapeDiver
Hause 3D 2.0.gh (187.9 KB)

I managed to upload your definition on a test account with 5 seconds limit without any difficulties. Could you post a screenshot of the upload error? Also, there are materials with textures so it might be worth checking their size, see this Forum post:

Hello here is the screenshot from the email I’ve got:


Thaks for the link regarding texture I’ve already red the article I will work on the otimization of textures, but I think it’s not the problem this time, am I right?
So maybe I should just try to upload the model again?

The values in the email are not correct and it seems that something went wrong between our backend and the emailing system.

Could you try re-uploading your model? If you get any error on upload please share a screenshot from ShapeDiver. More on platform errors in this Documentation article:

Hey, I’ve managed to upload the model. In my opinion answer is simple 1. the values in email were incorrect (as you said) 2. the model is calculated arround 5s, so sometimes it crushes.
link to uploaded model: hause config test 2.6 - ShapeDiver

Since I’m testing model before getting a pro version, and I need to make key decisions about the algorythm. I have three more related questions:

  1. Is sending and rendering model included computation time limit (5s), or its just model processing on your server?
  2. Is there significant difference between computation time in FREE and PRO version?
  3. Is cashing arround 1500 versions possible, or should I limit myself to fewer possibilities?

Great to see that your model works. The only problem you encounter is the computation time limit and you get in session warnings if you cross it. There are different ways how to improve the performance your models and following video tutorials can help you to achieve that.


To answer your questions:

  1. Computation time only includes processing on the server side, read more in this blog post:
  1. PRO account comes with 10s of computation time and can be extended up to 30s which makes a lot of difference when building online configurators. Also, embedding of models is not available for FREE accounts. Both FREE and PRO accounts are on the shared system and the performance is the same. Enterprise account on the other hand provides more performance and flexibility, see our pricing page for details.

  2. One of the main advantages ShapeDiver offers to its users is the model hosting in a robust and scalable infrastructure which makes caching of thousands of solutions possible so don’t limit yourself.

Read more about computing in cloud and get inspired by work of our clients:

Hi Pavol.

In a model from the Dampere company I followed all the recommendations and a model that is max 100ms is exceeding the limits for a bussiness account. The code is 19mb, but there are several gates that isolate the parts that are not being used.

Even trying to upload with the simplest form which is a v811 f801 mesh the file doesn’t upload.

A few months ago I uploaded the same code and it worked fine. Now I made some changes to reduce the amount of meshes and now it is showing this error.

This was the code informed.
2ff29007-4909-476a-8d6a-09e9dd4c168b

Was this a computation time error or an error because the code is too big?

Any suggestions on what might be happening?

Thanks

Pedro

In most cases, our servers can’t perform an exhaustive checking of all possible parameter sets. Therefore it is possible that model checking succeeded in the past even though some parameter sets take longer than the time limit to compute and you hit the limit with this upload.

Can you try re-uploading the model? If it fails again, try to isolate the problem and post a minimal version of the definition so we can have a closer look.

1 Like

I tested it with minimal parameters but it didn’t work.
I believe this code has reached a limit.
I will test a minimal version and try to upload.

Thanks.

Hello Pavol. I took half of the code and tested it to see if it worked.
It worked once, but when I made new updates it didn’t work anymore.

I’m noticing that simpler codes have this problem.

Have there been any changes to the testing protocol on uploading files? I send the link of the last file that the upload worked.

I’ve been improving this code since December with new updates, and now it has fewer components but more data internalized.

Does this have any interference?

The customer will be launching the site next week and I am concerned about this issue.

Your model is simply too close to computation time limit and it crosses it in some parameter combination. Internalising geometry is a trade off between processing time and time for opening the definition. While the logic is simpler, heavy meshes might delay opening of the model.

It seems to me that some parameters are relevant for manufacturing but don’t have direct impact on the model you need to render while configuring the product. You can separate the manufacturing logic with a toggle and let user interact with a lighter model optimised for rendering in viewer. Only after the configuration step is finished, you enable processing of the manufacturing model and export.

Reviewing the logic, optimising and replacing operations that take long with smarter ones can also help.

1 Like

Hi @pavol thanks for the answer!

I did some tests and checked the limits defined by the shapediver to find out what the problem is with the loading.

When I inserted a file with less than 20mb it worked.

Definition file size limits

I’m going to split the code into two, one for rendering and one for manufacturing.
I will also make a reduction in the geometry of the meshes.

Still, the curves that are internalized within the definition exceed the 20mb limits for the PRO account.

I did some tests by hosting these curves in a folder, but the SDGeometryInput component demands a lot of computational time.

What do you suggest in this case?

It looks like you are importing lot of polylines and that just needs its time.

  • How about creating the curves parametrically? This could reduce overall response time and give you more flexibility.
  • If the curves are too complicated to do parametrically, try simplifying them first in Rhino or separate Grasshopper definition and then internalise them. By reducing number of segments the curves could fit in 20MB file.
  • Any chance to you could reduce the number of input polylines? I’m wondering if there is a way to make your definition more elegant and make a generative pattern instead.
1 Like

We are going to take a more generative approach in another code for the same client, but for this one we need the original factory pattern, as these are the patterns sold by this client.

I’m going to separate the code between render and fabrication, reduce the mesh vertices, and making copies with the C# component you provide but we’re still going to need more storage.

Is there a way to increase the storage capacity inside ShapeDiver?

The size of the Grasshopper definition file can be increased by upgrading your account:

  • Business: 50MB
  • Enterprise: by default 200MB, but can be lifted for specific applications

You can change your subscription in Manage Account section in your dashboard. For details on Enterprise account contact our sales team via the form at www.shapediver.com.

1 Like

Thanks Pavol

We reduced the definition size to less than 20mb and the error “Computation of your model failed” continues.

I performed some tests to identify where exactly in the code is the error “Computation of your model failed”

Parts of code for generating manufacturing files are isolated by gates that are activated only when the user finishes the configuration.

FIRST TEST - Assess if the error is in the part of the manufacturing code.

I deleted all the code to manufacture the definition was with 16mb. I tried to load in shapediver and the error continued. If the error was in this part I could split the code in two, render and manufacture to optimize the code.

SECOND TEST - Evaluate if the error is in the complexity and quantity of meshes that are sent to the ShapeDiverDisplayGeometry component.

I disconnected all meshes from the component and tried to load in shapediver and the error continued. If the problem was here I should create another technique to optimize the creation of meshes.

THIRD TEST - Assess whether the error is in the definition size is too large.

The code has two types of patterns that have been internalized, one for horizontal position and one for vertical position. Some patterns just rotate the horizontal pattern through the code, in others I need to internalize a different design in the vertical position. All patterns were pre-designed with fewer points to work better in ShapeDiver and meet the 20mb limit for the customer’s account.
I deleted all vertical patterns and uploaded to ShapeDiver. The setting was at 10mb and it worked. ShapeDiver loaded the definition.

We need the horizontal and vertical patterns in the definition.
The definition is only being accepted with half the limit allowed by the customer’s account.
Does the ShapeDiver team evaluate this definition?

Sorry for the delay @pvilarim . Can you help me by giving me the id given with the “Computation of your model failed” error?
It might be linked to the time it takes for Grasshopper to just open your file. How long does it typically take when you launch Grasshopper and then load the model for the first time?
I can confirm that and in any case give you more details if you give me the reference id for the error.

1 Like