Shapediver file size issue

Hello,

We have generated attached 3D models and both these grasshopper file size is just 4MB. But when we upload them into ShapeDiver it’s converting to a way bigger file which is crossing the 20MB limit for our Pro account. We really need help to understand how this conversion works in ShaeDiver so we can try optimizing these models so they can fit within the 20MB limit.

If anyone of you has encountered the same issue, please provide details so we can resolve it. Thanks

Cross Cap.gh (3.5 MB) T Cap.gh (3.5 MB)

Hello,

Have you tried to host the texture files on a webserver instead of internalizing them on your definition? This would make the file much smaller.

Textures are not the problem, they have reasonable size. But as suggested by @Filipe_Brandao, hosting them externally would give you more flexibility if you decide you change them in future. Keeping them in Grasshopper is perfectly fine too.

It’s not about the file size but huge meshes the model generates - output size. The wireframe is created as pipes and fed to the ShapeDiver Display component as unoptimised breps. I recommend to use Pufferfish Parameter Pipe Mesh component instead which gives you control over the resolution of the geometry output. You can download supported version of the plugin here.

T Cap SD1.gh (3.5 MB)

Also, you input breps to the ShapeDiver Display in other parts of your definition. All breps and surfaces are converted to meshes automatically for rendering in the web viewer which can give unexpected results. I would suggest to review some logic in your model and either convert all breps to meshes or create the objects as meshes straight away. More in tutorials below:


thanks for the details. We will try to implement these inputs and let you know if any questions.