Shadows which are not sharp

Does anyone have any idea why shadows of my objects look like this? I want a sharp, correct shadow and I’ve literally tried all the different settings and it just won’t output as a clear, sharp edge, correct shadow. This is what it looks like, and here are its settings. If anyone has an idea what is wrong, please help. I’m using Rhino 7 and my computer is MacBook Pro 16’'.

maybe too far from world origin?

If the issue wasn’t distance to 0,0,0… run the command SystemInfo and post the resulting text file. Also post a sample 3dm file that shows this issue in the default Rendered mode.

Hello Brian,

I made this box at the world origin so that is not the issue. This is what it looks like in the default rendered mode.

Here is the SystemInfo:

Rhino 7 SR4 2021-3-19 (Rhino 7, 7.4.21078.01002, Git hash:master @ a432d22ab7f0f7b53d157d578278070c8bf6eff4)
License type: Evaluation, build 2021-03-19
License details: Cloud Zoo
Expires on: 4442750-02-12

Apple Intel 64-bit macOS Version 11.2.3 (Build 20D91) (Physical RAM: 32Gb)
Mac Model Identifier: MacBookPro16,1
Language: en-US (MacOS default)

AMD Radeon Pro 5300M OpenGL Engine (OpenGL ver:4.1 ATI-4.2.15)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4080 MB
Graphics: AMD Radeon Pro 5300M
Displays: Color LCD (264dpi 2x), S27F350 (82dpi 1x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
AMD Radeon Pro 5300M (4 GB)
Color LCD (1792 x 1120 @ 59.00Hz)
S27F350 (1920 x 1080 @ 60.00Hz)

USB devices
Apple Inc.: USB3.0 Hub
D-Link: DUB-E130
Apple Inc.: USB-C Digital AV Multiport Adapter
Apple: composite_device
Apple Inc.: Touch Bar Backlight
Apple Inc.: Touch Bar Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: Ambient Light Sensor
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple T2 Controller

Bluetooth devices
Nordic Semiconductor:

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino “Snapshots” 7.4.21078.1002
/Applications/Rhino “PanelingTools” 7.4.21078.1002
/Applications/Rhino “AnimationTools” 7.4.21078.1002
/Applications/Rhino “Renderer Development Kit” 7.4.21078.1002
/Applications/Rhino “Displacement” 7.4.21078.1002
/Applications/Rhino “Legacy Rhino Render” 7.4.21078.1002
/Applications/Rhino “Commands” 7.4.21078.1002
/Applications/Rhino “Import_OBJ” 7.4.21078.1002
/Applications/Rhino “export_xaml” 7.4.21078.1002
/Applications/Rhino “QuadRemesh” 7.4.21078.1002
/Applications/Rhino “export_OBJ” 7.4.21078.1002
/Applications/Rhino “RDK_EtoUI” 7.4.21078.1002
/Applications/Rhino “Export SVG” 7.4.21078.1002
/Applications/Rhino “MeshCommands” 7.4.21078.1002
/Applications/Rhino “Export_DAE” 7.4.21078.1002
/Applications/Rhino “PDF Export” 7.4.21078.1002
/Applications/Rhino “IGES Export Plug-in” 7.4.21078.1002
/Applications/Rhino “Import_SVG” 7.4.21078.1002
/Applications/Rhino “BlockEdit” 7.4.21078.1002
/Applications/Rhino “Export_AMF” 7.4.21078.1002
/Applications/Rhino “Rhino Render” 7.4.21078.1002
/Applications/Rhino “Import_DST” 7.4.21078.1002
/Applications/Rhino “PLY - Polygon File Format Export” 7.4.21078.1002
/Applications/Rhino “Import_AMF” 7.4.21078.1002
/Applications/Rhino “RhinoCycles” 7.4.21078.1002
/Applications/Rhino “IronPython” 7.4.21078.1002
/Applications/Rhino “Grasshopper” 7.4.21078.1002

Your Mac should be fine. Try making a new file from a template using the File drop down menu. This will create a file with the default Rendering panel settings. For instance, the Ground plane will be set to shadows only and the Sun won’t be on as it is in your last screenshot. Then run the Preferences command and in the Display Modes section select the Rendered mode from the list on the left and click Restore Defaults from the top right of the Preferences window. Then make a box and enter Rendered mode in the Perspective viewport. You should see soft shadows around the edge of the box (from the skylight setting in the Rendering panel). Then run the Rendering command to open the Rendering panel. Go down to the Lighting section and enable the Sun and then open the Sun settings from the button there. Switch to manual control and move the Sun around to check for the shadow from it.

If you don’t see the shadows from the skylight, sun or both with the above steps, close Rhino 7 and disconnect your extra monitor. Then start Rhino again and test the above sequence of steps another time. Any luck?

Here’s what it should look like…