Render View Shadows Incorrect


#1

I am working on doing a sun-study in Rhino for Mac and my Rendered View is not giving accurate shadows. The Shadows in Render View are oddly offset. They are fine when actually rendered. I have gone in and basically tried to adjust every setting in the Preferences>Display Modes>Rendered.

Here is an image of what I am talking about. The box that you see is sitting flush on the surface. There is a single directional light setup. The problem is also in the technical mode.

The second image is the system info for this setup I am working on.

EDIT: Originally thought I was posting to a thread from November 13. Edited out that I had tried those resolutions first before posting.
EDIT 2: Added information about the light setup and other modes.


#2

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-03-05 (505)
OS X version: Version 10.9.2 (Build 13C64)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: Macmini5,2
Processor: Intel Core i5-2520M CPU @ 2.50GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD Radeon HD 6630M 256 MB
Memory: 256 MB
Screen size: 1920 x 1200
Displays: Cinema HD

USB devices
Western Digital : External HDD
Apple Computer, Inc.: IR Receiver
Apple, Inc: Apple Keyboard
Logitech: G9x Laser Mouse
Apple Computer, Inc.: Apple Cinema HD Display
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.20.11
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: None
Mip map filtering: None
Anisotropic filtering: None


(Brian James) #3

Hi Carter,

This looks like what will happen when the object casting the shadow is much smaller than the ground plane surface.

This happens in Windows Rhino 5 as well but there is a ground plane primitive object that helps decrease the offset some in that version of Rhino. Try making the plane you are using as the ground smaller without exposing the edges of it in the view you’ll use. The Windows version of Rhino also has a Sun object with GPS control and a default animation tool for a day light study. These features are not yet supported in the Mac version of Rhino.


#4

If you turn off “cast shadows” for the ground then this should improve. Is that hooked up in the Mac version?