Artistic & Rendered Viewport: No shadow

Hi there!

I’ve been using the artistic/rendered views in Rhino for Mac to get quick renderings with basic light and shadow effects. But lately I’ve come across that the shadows no longer show up in the artistic/rendered viewport - not sure if I messed up some setting or something? I’ve tried turning on/off shadows in the viewport settings as well as reinstalling/resetting all the settings but none seem to have worked.

If someone could offer some help or suggestions on how to fix this issue, that’d be much appreciated!

  • George

Hi George,

Did you recently update OSX to 10.11? Can you also post a sample 3dm and a screenshot of what you see?

Hi Brian, I am having the same problem on 10.9.5., so I am incorporating some screenshots and a 3dm.

Gastje_v1.2.3dm (2.8 MB)

Software information

Software versions
Rhinoceros version: 5.1 (5B161)
IronPython version: 5.1.2015.131
Language: nl (MacOS default)
OS X version: Version 10.9.5 (Build 13F1112)


Third party kernel extensions

Hardware information

Computer hardware
Hardware model: iMac10,1
Processor: Intel Core2 Duo CPU E7600 @ 3.06GHz
Memory: 4 GB
Architecture: Intel 64 bit

Video hardware
Graphics: ATI Radeon HD 4670 256 MB
Memory: 256 MB
Screen size: 2560 x 1440
Displays: iMac (109dpi 1x)

USB devices
Apple Inc.: Built-in iSight
Apple: Internal Memory Card Reader
Apple, Inc: Apple Keyboard
Apple Computer, Inc.: IR Receiver
Wacom Co.,Ltd.: CTH-661
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-8.24.17
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 bits
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 2x
Mip map filtering: None
Anisotropic filtering: None


@maxz Possibly the shadows have been automatically shut off by Rhino because your video card with only 256 Mb VRAM wouldn’t be able to handle them… However, I would have expected to see that in the preferences somewhere. --Mitch

Never mind the fault, Great plane. :smiley: Love those wheels.

Thanks for the sample file. I’m not sure what the issue is but I am seeing intermittent shadows here. @dan Any ideas? Tested in 5B161 on OS X 10.11

I don’t see shadows when opening the file and using Rendered mode, but I am able to see shadows if I place a plane under the model. If I add another object like a box, the shadows disappear again.

@Helvetosaur Hi Mitch,

Not enough VRAM seems unlikely. Here are a couple of pictures I made with 5A865 recently, shadows are clearly present:


(edit: the middle “bare bones”-picture is a shaded view, hence no shadows)

1 Like

Interesting. I’m not seeing this in 5B161 on OS X 10.10.5 with my hardware

Video hardware
Graphics: NVIDIA GeForce GT 650M 1024 MB
Memory: 1024 MB
Screen size: 2560 x 1440, 1440 x 900
Displays: Thunderbolt Display (109dpi 1x), Color LCD (221dpi 2x)

I get shadows when I give them something to cast upon…

…I’m left wondering if this is another Mavericks-specific issue or regression with changes for El Capitan.

@mary Do you see shadows in Artistic mode with 5B161?

those shadows should catch on the surfaces of the model as well… seems like all the faces which are pointing outward on this airplane are not accepting shadows… drag some polysurfaces around and for whatever reason, the inward pointing faces will work right…


• sub-object select this surface:

Delete (notice inside face is receiving shadow)

• select the remaining polysurface then _Cap

the shadow work properly on the new solid.


or select a polysurface then Explode then Join… the shadows will work.
something is up with those surfaces

Practically all my polysurfaces are extrusions from either a closed planar curve, or a flat surface. The one that Jeff picked was extruded from a flat surface.


That happens to me as well:

After ExtrudeSrf at a negative distance:

instead, at a positive distance:

_Explode _Join : 

I also tested backfaces vs. frontfaces: all polysurfaces except the wheel hubs and the motor shaft are correct, i.e. not inside out.



Hi Brian,

Apologies for the delayed response - have been pretty busy for the past two days…

I haven’t updated to 10.11 just yet, so that shouldn’t be the problem. I’ve also attached a sample file (which had shadows in Artistic viewport earlier on) as well as some screenshots.


20150927_Axon Render.3dm (749.5 KB)

Thanks everyone for the files and reports on what you’re seeing. I’ve filed this here for the developers.

Hello! I’m having some similar problems globally in Rhino for Mac 5B161. As a basic test, I made two boxes (one to cast a shadow on the other) and one directional light. I can see the appropriate shadow only when the upper box (the one casting the shadow) is selected. With nothing selected or both boxes selected, there are no shadows visible and it appears as if the objects are displayed with the “shaded” effect rather than “rendered” effect.

I hope this bug is fixed soon! It seems like a simple fix (unlinking object selection with display effects) because the shadow quality looks really nice already. Seems like the program has the capability, the shadows have beautiful crisp edges.

In my more complicated files, the shadows aren’t working at all, no matter if one object or none or all are selected.

About This Mac
OSX Yosemite 10.10.5
iMac 21.5 inch, Late 2013
Processor 2.9 GHz Intel Core i5
8GB 1600 MHz DDR3
Graphics NVIDIA GeForce GT 750M 1024 MB


same problem here, no shadows on rMBP 15 2014 and latest 10.11. Please fix asap.

This is something we are currently investigating (MR-2368). @jeff is working on this right now.

Just to chime in. I am experiencing this as well on the recent 5.1 update. All my models don’t show shadow any more. It works fine on Rhino Mac 5.0 on my other Mac, but not on my main machine with 5.1.

Currently running Rhino 5.1 (5B161) on El Capitan (10.11.1).

Funnily, I managed to get the shadows to show on every model consistently if I go File > Settings > Rhino Render > Background > Skylight (Checked).

This issue ought to be fixed in the next RhinoWIP. Stay tuned.