Shadows in rendered view appear in wrong position


#1

Hi there. It’s my first time posting here. Hoping someone can point me toward resolving this problem.

In the rendered (and artistic) view shadows are appearing out of position and sometimes inverted. I’m attaching a few images so hopefully you can see what I’m talking about.

Here’s the rendered view and shaded view:

There are no lights or anything other than what you can see here.

I’ve been having this problem for about a month now. Here’s some details about my system:

  • Rhino for Mac (I’m not running v. 491, but had similar problems with
    the preceding few versions)
  • Retina MBP 13" w Intel HD Graphics 4000

(Kyle Houchens) #2

written by John Brock, this may explain your issue-

—- (Added 3/14/2013)
Brand Intel
Model Intel HD Graphics 4000
NOT RECOMMENDED by: John Brock
Notes: Computers including 13” Apple MacBook, 13” MacBook Pro, and 13” Retina, and any brand laptop that only has the embedded Intel graphics chip, should be avoided for Rhino for Windows. This chip does not support Windows OpenGL adequately. You will be plagued with problems we can not fix. Many ‘Hybrid’ laptops also have a secondary ‘high performance’ graphics chip (by AMD or Nvidia), intended for graphics intensive applications, do work very well. These hybrid computers are recommended.


(Marlin Prowell) #3

Please post your OpenGL settings from Rhinoceros > Preferences > OpenGL.


(Marlin Prowell) #4

Please note that this is advice for Rhino for Windows only and does not apply to Mac OS X.


#5

HI Marlin! Thanks so much for your response. Hope this gives you a clue.

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2013-11-18 (491)
OS X version: Version 10.8.5 (Build 12F45)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: MacBookPro10,2
Processor: Intel Core i7-3520M CPU @ 2.90GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel HD Graphics 4000 768 MB
Memory: 768 MB
Screen size: 1440 x 900
Displays: Color LCD

USB devices
Kingsis Peripherals: Evoluent VerticalMouse 4
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 INTEL-8.16.74
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


(Marlin Prowell) #6

Rhino had some special code to handle shadows on the HD 4000. The technical term for this special code is “hack”. It’s no longer necessary and has been removed. This problem will be fixed in the next WIP release.


#7

Thanks Marlin! I also found that if I turned off “advanced GPU lighting” it fixed the problem

Rhino>Preferences>Display Modes>Rendered>Lighting Scheme> Uncheck “Use advanced GPU lighting”

Weirdly this only worked for the rendered style, not the artistic style.