Shadow errors in rendered viewport

I am using rendered viewport with shadows turned on, utilizing sun for light, and the shadows incorrectly appear offset from objects. This is a viewport issue, not result of render command. Any idea why shadows do not connect to the objects casting them?

Hi Matt - can you post the vertical objects and the plane they are sitting on?

thanks,

-Pascal

Yes - sure.

Added additional geometry to further show the problem. Notice also that the person as single surface also does not cast shadow at all.Rhino 5 shadow error model.3dm (1.3 MB)

Hi Matt - you can make this somewhat better by, in the rendered mode settings in Options > View >Displaymodes:

  • Slide the Video memory slider to the right, to taste.
  • Slide ‘Self shadowing Artifacts’ to the left.
  • Shrinking the camera based clipping bubble. (Slide to the left)

-Pascal

Thanks, Pascal. I had already done exactly that… The best result was with those settings but I still get the weird shadow offset. Could it be anything else? Here’s what I have:

Actually, I just discovered that sliding the camera based clipping bubble slightly over to the right from ‘none’, but not too far, mostly fixed the problem.

Matt

Yeah, that’s it - I should have said, slide that one left but not all the way to the left, which turns it off.

-Pascal

Pascal,

This shadow problem is recurring (offset shadows in rendered viewport) and the clipping bubble is no longer helping (and when I use it, the whole image is not shadowed, only a portion). I can find no solution to this weird displacement of shadows. Also notice in this image the jagged shadow edge. Is this just a limit of this viewport shadow functionality? It seems odd.

Thanks,

Matthew

Hi Matthew - is the scene very large? If you hide parts that are distant from the current view, does it change the shadowing?

-Pascal

Pascal -

No, this is a smallish model, with only the building and some adjacent ground plane objects (but nothing distant, not high polygon count, etc.).

Matthew

Hi Matthew - just as a test - hide the ground planes… any different?

-Pascal

Here’s the problem shown with the rest of model turned off. Shadow offset and jagged (see white part).

Here are the settings:

Hi Matt - is this new V5 behavior or has it always been like this? What video card are you using, can you post an image of your Options > View > openGL page? Does noodling with the ‘Soft edge quality’ slider do anything for the jaggies?

-Pascal

Pascal,

This is not new behavior - the shadows have had this issue in rendered viewport for some time. I don’t know that they ever aligned properly or were not jagged. The soft edge adjustment doesn’t help, it just makes the shadows blurry and the offset still occurs. Here’s my open gl page.

Hi Matt - I see the driver is more than a year old - I don’t say it will fix it, but you might want to update that. Messing with your model some more, I can clean things up quite a bit with the clipping bubble and edge quality slider. The bubble needs to be just large enough to allow shadows into the visible part of the scene - remember all the way left shuts it off completely- you need to slide it off the stop on the left side.

-Pascal

Hi Mathew, Hi Pascal!
I had the exact same problem and it was driving me completely crazy!
I think it really must have to do with the camera clipping bubble(–whatever that is–). too small objects just didn’t cast any shadow at all!!!

since my model is quite large (landscape) i figured i could be i am too far away of the origin(since i use absolute pos values) i figured that might cause the problem…
so i finally decided to move my model to the origin 0,0,0

and: everything just works perfect!!! hope this is some help to you, martin

by the way --i still have the same 'flying’shadows mathew was talking of–> see

Hi - could you post a 3dm file that shows this behavior? Also, please run the Rhino SystemInfo command and post the result here.
-wim

Hi Wim!

I include parts of my file—since all of it would be too big
The Problem remains the same…. (i also include a screenshot of what i mean…)

Thanks, martin

Systeminfo:

Rhino 6 SR19 2019-10-22 (Rhino 6, 6.19.19295.01001, Git hash:master @ 0af62045bd35259d4c2367dbf7f9ef94ded29299)
License type: Educational, build 2019-10-22
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 12Gb)
Machine name: I5

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 750 (NVidia) Memory: 2GB, Driver date: 10-27-2017 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 388.13

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-27-2017
Driver Version: 23.21.13.8813
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

rhino_part_landscape.3dm (6.8 MB)