Rendered-view shadows

unhandled

#1


Any chance these weird shadow effects will be fixed sometime soon?


(Miled Rizk) #2

Hi,

From File menu, go to properties, View, expend Rendered, click Shadows,
On the right you can change few settings for the Shadow, in your case you
The option Self-Shadowing Artifacts, you can bring the slider to the Left


#3

Hi
Thanks for the suggestion, it helps a little but doesn’t solve the problem. The trouble is I keep being fooled into thinking surfaces aren’t meeting. This has been like this for years.


(Nathan 'jesterKing' Letwory) #4

What does your _SystemInfo in Rhino say?


(Miled Rizk) #5

Yes, true, it helps a little, but not 100%, specifically when the object has no thickness.
I’ve found that in addition to the Self Shadowing option, increasing the Edge Blurring a little +
Increasing Video Memory Usage/Shadow Size, will add to the improvement, but again not 100%
You’ll keep seeing some Artifacts.


#6

Hello Nathan
System inf below:

Rhino 6 SR2 2018-3-6 (Rhino 6, 6.2.18065.11031, Git hash:master @ cd4fa1dcdec31cb58baacef0855771173af7196f)

Windows 10.0 SR0.0 or greater (Physical RAM: 6Gb)

GeForce GTX 650/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 390.77)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-23-2018
Driver Version: 23.21.13.9077
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”