Shadow does not show up in render view port when i use a rectangular light

Hi all,

I am having issues with the shadow in the view port for some lights, see below.

Rectangular light shadow does not show up in render view port but it does show up when i do a production render.

Linear light shadow does not show up in render view port but it does show up when i do a production render.

Spotlight shows up in render view port and production render.

Direct light Shows up in render view port and during production render.

I have Skylight turned off, it really slows down my render times.

Is the shadow not showing up in the view port a known bug or am missing sth?

Thank you


What’s your active renderer? Also, if you’re using Rhino 6 for Windows, what does your SystemInfo say about the graphics driver? Either of those things could impact Rhino lights. If you are using light objects from another render plugin they may not support the Rhino Rendered mode.

Hi Brian,

For this situation I am using rendered view, haven’t changed anything in options. I looked at settings and the Display pipeline is OpenGL. Realtime display engine has two options Cycles and None. I have None selected.

I am not using Cycles (raytraced) for the preview (if i switch to Cycles the shadows work just fine).

Below are my system settings.

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Commercial, build 2019-02-27
License details: Cloud Zoo. In use by: Stylianos

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1080 (NVidia) Memory: 8GB, Driver date: 3-17-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 419.67

Secondary graphics devices.
NVIDIA Quadro M4000 (NVidia) Memory: 8GB, Driver date: 3-17-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-17-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\stsat\AppData\Roaming\McNeel\Rhinoceros\packages\6.0\raytraced-blend-material\1.3.0\RaytracedBlendMaterial.rhp “RaytracedBlendMaterial”
C:\Users\stsat\AppData\Roaming\McNeel\Rhinoceros\packages\6.0\rhinopbrmaterial\1.0.1\RhinoPbrMaterial.rhp “RhinoPbrMaterial”

Unfortunately that does not support shadows for rectangular lights.
But try turning on Raytraced and you get glorious shadows :wink:

Hi Holo,

Thank you for clearing that up, I appreciate it!! I use Raytraced (cycles), I am a fan!!!

I was curious about the rectangular light shadow in basic rendered view in the view port preview, but since its not supported, ok…

Do you think the developers will tweak it at some point, its strange that linear and rectangular lights are not supported but the other ones work…?

Thanks again


The reason is that rhino calculates shadows in OpenGL only from spotlights (and a pointlight is kind of a set of spotlights, so I know linear lights could be simulated with multiple pointlights, and the same with rectangular, but at a cost since many more shadows would have to be calculated for every single frame (as I don’t think Rhino stores the shadow information)

So a spotlight makes a “hard” shadow, but it appears soft if the object is small compared to the light since the shadowmap isn’t super highres and the interpolation of that information will be a gradient. (if that makes sense)

But with modern RTX cards and realtime raytracing we will hopefully see some nice upgrades in the future…

Thank you Holo.

I appreciate your input! I hope so too.

Do you know if why it takes so long to render when skylight is enabled? Even at good quality the image is grainy.


To answer that I need to see an example and to know what resolution you work with and on what system :slight_smile:

Oh, I see the system! Nice system!

Thank you!!!

I usually render with 1920 x 1080 at 300 dpi, i hope i answered your question… is there a different setting to tweak it?


Hi, well the 300dpi should not affect the size since renderings only care about the pixels and the dpi only tells the real world what default size to print it at.

But as you can see my example took 6 seconds for 50 iterations, (note 50 isn’t many iterations) so if you still see grainy images at that few iterations I presume you have either a large scene or shiny materials. Could you post an example image?

If you are using Raytraced with ViewCaptureToFile/Clipboard to render and you find things too grainy you should install the denoiseraytraced package using the _TestPackageManager command. Once setup properly (use DenoiseRaytracedCheck and follow instructions) you should see quite some time savings and much smoother results.

If you’re using Rhino Render with the Render command then… I don’t know (:

1 Like

Hi Nathan and @Holo ,

Sorry for the confusion, Cycles (raytrace) is awesome. I have installed DenoiseRaytracedCheck and it works great.

I am getting noise and long render times from the basic renderer (not cycles) when the skylight dome is activated.

Thank you


1 Like

Ah… yeah… the Rhino Render… don’t get me started :wink:

Nathan made an excellent Cycles render plugin too, that didn’t make it to Rhino 6 as default, but you can install it through the hidden and also great _TestPackageManager:

Great for larger than screen renderings. But @nathanletwory does this support Denoiser too? If not, could you update it so it does? Together with supporting Raytraced view that would be awesome!

1 Like

Not at the moment.

Maybe - currently the viewcapture method of DenoiseRaytraced is (much) faster than the production renderer.

It indeed would be. :slight_smile:


Hi Nathan and @Holo,

THANK YOU!!! I just tried rhino-render-next, it is amazing!!! I literally did one render and my jaw dropped.

Thank you!!!, I appreciate all of your help and expertise.


rhino-render-next is nothing more than Raytraced in the render window :slight_smile:

Yes, but you get too use all the goodies in the render window too that capture to file or clipboard doesn’t have.

If I feel I need to postpro I generally do that in the compositor of Blender, or just with GIMP. But if you’re happy with the postpro effects from the Render Window you definitely should use them (:

1 Like

Oh, it’s more, it has realtime feedback on higher than screen resolution and you can’t accidentally move the view and you can safely save it after it is done without using hidden viewcaturetofile commands.
And you can set the resolution and always get the same size in a known environment.
(So as you see these points are all about userfriendlyness and has nothing to do with technology from my point of view :slight_smile: )
((But I rarely use it since I’m a nerd and viewcapture hacking has become normal for me, but I hesitate to recommend viewcapture to customers))

1 Like