Model won't stay shaded/rendered

unhandled

(Grace E Bader) #1

Just downloaded the Rhino 6 Evaluation. I have limited experience with Rhino but know a viewport should stay shaded once that option is selected as I have done it on another computer that has an older full version. It will shade for a second but as soon as I move the model inside the viewport it will turn back into wireframe.

My computer has ample space/power and shouldn’t be having issues with this so I’m wondering if it’s a bug with the evaluation version or what I can do to overcome this issue.

I appreciate any insight. Thank you.


(Wim Dekeyser) #2

The evaluation version and the full version are the same.
Could you post the outcome of the Rhino SystemInfo command?


(Grace E Bader) #3

Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

GDI Generic (OpenGL ver:1.1.0)

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Anti-alias mode: 4x

Mip Map Filtering: Linear

Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation

Render version: 0.0

Shading Language: Not supported

Driver Date: 10-27-2017

Driver Version: 23.21.13.8813

Maximum Texture size: 1024 x 1024

Z-Buffer depth: 32 bits

Maximum Viewport size: 16384 x 16384

Total Video Memory: 6 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”

C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”

C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”

C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”

C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”

C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”

C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”

C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”

C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

I see here that the “shading language” is not supported. If you could let me know what I need for that to change that would be great. Also if you see other issues with running any part of the program let me know.

Thank you.


(Pascal Golay) #4

Hi Grace - there are two commands that might be getting muddled’

Shade is a temporary shaded state that reverts to the viewport mode as soon as you click in the view, that is the left ‘shaded looking’ icon. The other is SetDisplayMode > Shaded , that stays until you change it.

image

-Pascal


#5

That doesn’t look too good. What do you actually have as a video card? Looks like it’s not being used…


(Grace E Bader) #6

I appreciate your quick response Pascal! I tried both buttons now. The Temp shade button either does nothing or shades it for a split second whether or not I try to move the viewport. The Shaded mode shades the viewport but once I move around in the viewport it goes back to wireframe. If I click back on the model it shades again. I tried the ghosted and rendered modes too just to see but ended up with the same result.

I saw if you right click it’s supposed to shade all viewports. That doesn’t work at all and only the viewport I’m in is shaded (again until I move around).

Grace


(Pascal Golay) #7

Hi Grace - yeah, I think Helvetosaur is onto the real problem here - what video card do you have on that machine? Rhino is not seeing any…

-Pascal


(Grace E Bader) #8

I have tried the program on two separate computers. I first tried it on a laptop with no dedicated graphics card (just to see if it would work) and the model wasn’t rendering/shading, so I tried it on a desktop computer with an ASUS GEFORCE GTX 1060 OC 6GB and it had the same issue.

I’m running Windows 10 on both computers. Could there be an issue with the program there?


(Pascal Golay) #9

Hi Grace - does this happen with any file, even a new one with just a box or something simple?

-Pascal


(Grace E Bader) #10

Yes, I tried it on a simple one rail sweep and also a box.


(Pascal Golay) #11

Hi Grace, that does seem very strange, behaving this way on two different machines. Can you verify that on the GeForce equipped machine , Rhino sees the card and shows the correct, or expected info in Options > View > OpenGL page?Maybe best is to run SystemInfo on both machines (Help menu > System information) and paste the results here…

-Pascal


(John Schindler) #12

I see the same problem here. It happens with very large models, like complete buildings (with furniture etc.) comprising many blocks. The rendered view changes to wireframe mode during view rotation, and it happens on different computers.
The same files do not exhibit the same behaviour in Rhino 5.


(Grace E Bader) #13

The SystemInfo I posted the first time was for the desktop with the GeForce. Below is the SystemInfo for my laptop:

Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 10.0 SR0.0 or greater (Physical RAM: 5.9Gb)

GDI Generic (OpenGL ver:1.1.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 5-19-2016
Driver Version: 9.17.10.4459
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2076 MB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Here is the information for my laptop when I go to Options>View>Open GL page. (I will post this for the desktop as well when I get over to it.)

Microsoft Corporation
GDI Generic
OpenGL version: 1.1.0
Render version: 0.0
Shading Language: Not supported
Driver Date: NA
Driver Version: NA

Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32bits
Stencil depth: 8bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB


#14

That’s odd, doesn’t look like the graphics card is detected at all on either machine…


(Grace E Bader) #15

Alright, here is the System Info for the desktop with the Geforce:

Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

GDI Generic (OpenGL ver:1.1.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 10-27-2017
Driver Version: 23.21.13.8813
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 6 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

This is when I go through Options:

Microsoft Corporation
GDI Generic
OpenGL version: 1.1.0
Render version: 0.0
Shading Language: Not supported
Driver Date: NA
Driver Version: NA

Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32bits
Stencil depth: 8bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB


(Grace E Bader) #16

Any idea on how I can fix that?


#17

I wish I did… but I don’t.
Is your Windows 10 install completely up to date?


(John Schindler) #18

Hi Pascal, once you showed these buttons, it always bothers me that the next, blue buttono starts the Render rather than the Rendered View, which would be more logical. Since the Renderd View Is used more often than Render, it would make sense to assign it to this button, with Render assigned to the left click.