Rhino 6 will not display my image in rendered, ghosted, x-ray, or shaded

My object( a ship’s hull) appears fine in wireframe display, but does not work when I try to use any of the displays listed in the title. The hull will show up correctly at first, but when I try to zoom or pan it immediately goes back to wireframe. I know there are are kinks in my hull I need to smooth out but I cannot see them in wireframe so I really need these other displays to work. Please Help!

May be a video driver problem… What does _SystemInfo (command inside Rhino) tell you? --Mitch

Rhino 6 SR0 2018-1-16 (Rhino 6, 6.0.18016.23451, Git hash:master @ c0b115e88c59340755c25f7822e172c79c9b530b)

Windows 10.0 SR0.0 or greater (Physical RAM: 7.9Gb)

GDI Generic (OpenGL ver:1.1.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 5-19-2016
Driver Version:
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2108 MB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

I see that it says shading language is not supported and that is probably the problem but I don’t know how to change that

@tcampbell What GPU do you have?

I would recommend you uninstall your GPU driver and restart your computer. Then, download the latest GPU driver version from the internet, and restart again.

Does that work?

Not just “from the internet” as there are a multitude of 3rd party sites that purport to have the latest drivers, and some of them are actually reputable and do what they say and only that. Then there are the rest. I don’t know how to tell the difference.

Get your drivers from the GPU card manufacturer’s driver download website.

If you have a notebook, the computer manufacturer may have more recent drivers than the one you have, but it may not be the latest from the GPU manufacturer.

my graphics driver is Intel® HD Graphics 3000. I clicked the update driver button and it says “windows has determined the driver software for my device is up to date”. Do I need to download a different driver?

From the internet in your case would mean the intel.com website.

ok… but how do I know which driver is the one I need. There are 4 latest options for windows 10, 64-bit and I don’t want to mess up my computer

I don’t know how well it will work in any case with an HD 3000, that’s sixth gen first made in 2011, they’re on 9th gen now… The 3000 and 4000 series didn’t do so well with with Rhino 5 IIRC. Don’t know if any support has really been added for V6.


I encountered the same problem and solved it using RefreshShade

RefreshShade did not work for me, but RefreshAllTextures did!

1 Like