SetObjectDisplayMode now asking new question, and not working?

Hey guys

I updated to the most recent Service Release Candidate and now I get the following when I try to do SetObjectDisplayMode:

“Choose attributes for selected objects:”

Any idea what’s happening?

Rhino 6 SR15 2019-5-7 (Rhino 6, 6.15.19127.12061, Git hash:master @ 1ad7f43a70c96f327e9efba4674dfdbcaabdf4fa)
License type: Commercial, build 2019-05-07
License details: Cloud Zoo. In use by: Alan Farkas ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-RO9R8FT

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2070 (NVidia) Memory: 8GB, Driver date: 4-17-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 430.39

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-17-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.15.19127.12061
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.15.19127.12061
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\RealDrawings (9aaa3b93-9ea4-4425-b44e-8a8c4500c274)\1.0.7030.16466\RealDrawings.rhp “RealDrawings” 1.0.7030.16466
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.15.19127.12061
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.15.19127.12061
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.15.19127.12061
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.12.6.531\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

Hi @Alan_Farkas - I believe that’s the standard wording in the command line for that command. You should also see (Mode=UseView) right by it. This should be a clickable option that allows you to choose a different display mode for the selected object. Is it not the case on your end?

Correct - I don’t have that text string anymore. that’s the problem

Thanks for clarifying! It seems to be working here (in a slightly more recent version that is).Can you try starting Rhino in Safe Mode? You won’t actually be able to change to another display mode other than Wireframe, but at least we can see if the Mode=UseView option is available. Just want to make sure it isn’t one of the external plugins installed playing tricks.

Thanks, Vanessa. Do you work for Rhino?

I won’t be able to do safe mode right now during work. Will have to try maybe tonight or tmrw morn.

Sounds good! And yes, I work for McNeel. It’s been a while now ;-).

Tried Safe Mode - it still has the same problem

Hmmm… That is odd. I just installed SR15 here and it is working. Try running the command > pressing M + Enter > to see if the command is there and working, but just not printing to the Command line. If it is there, you should get to a prompt like this one:

Also, can you send a screenshot while the command is running? Maybe there’s something we’re missing that we can catch in the image.

I had tried that. It didnt work. Nothing happens while running the command. It just says that line I originally posted and nothing else.



Hi Alan - are you typing the command or getting it from a button, or?


typing it. tried allowing auto-complete to do it, and also tried typing full string. Will try a button…

Tried. No love. Attached screengrab of the “process”

Hi Alan - shooting in the dark but by any chance do you have a non-standard alias that might be getting in the way? is there anything in Options > Aliases that looks suspicious?


Hi Alan - that looks reasonable - can you do one more thing - run the command and after it gives you the unexpected feedback, exit and press F2 - copy and paste here as many lines of command history as needed to get to the command before the weird one…


opened new file and made a cube and tried it.

Loading V-Ray for Rhino, version 3.60.03 adv ( Jul 3 2018 )
Loading Rhino Render, version 1.50, May 7 2019, 12:24:38
Command: _Box
First corner of base ( Diagonal 3Point Vertical Center ): _3Point
Start of edge
End of edge
Width. Press Enter to use length
Height. Press Enter to use width
Creating meshes… Press Esc to cancel
1 extrusion added to selection.
Command: SetObjectDisplayMode
Choose attributes for selected objects
Command: _CommandHistory

@jeff - do you have any idea why Alan might be getting this prompt when running SetObjectDisplayMode

Command: SetObjectDisplayMode
Choose attributes for selected objects

instead of

Command: SetObjectDisplayMode
Select objects to set their mode


BTW, @Alan_Farkas - does it do anything to set the mode??


and FYI even if I have the object selected to begin with (or select it afterward) it’s the fact that I get “choose attributes for selected object” instead of the text that usually has “(Mode=UseView)”

It sounds like command collision… Do we know what command (if any) outputs

“Choose attributes for selected objects”


What happens if you type the English-interactive version of the command?

For example:


Note the hyphen and underscore.

Any different?


no difference

Newest update(s) of Rhino 6 - Still not getting SetObjDisp to work. Anything we can do?