SetObjectDisplayMode now asking new question, and not working?

Hi @Alan_Farkas,

Looking at the code I see this:

  CRhinoGetString   gopt;
  
  gopt.SetCommandPrompt( RhLocalizeString( L"Choose attributes for selected objects", 17124) );

  DisplayAttrsMgrList   dalAll;
  DisplayAttrsMgrList   dal;
  int                   nNumAttrs = CRhinoDisplayAttrsMgr::GetDisplayAttrsList( dalAll );
  
  if ( nNumAttrs == 0 )
    return CRhinoCommand::failure;

Most of the that probably doesn’t mean anything to you…but I show it here because it shows that the only time the command would only produce just the prompt and nothing else, is if/when the display attributes manager failed to return any display modes (which is supposed to be impossible since Rhino guarantees the existence of the built-in modes)… Therefore…

This tells me that it might be possible that you have corruption in your display modes that is somehow preventing the manager from collecting any of the modes on your system.

When you go into Options->View->Display Modes… what do you see? It should look something like the following:

Could you please post a screenshot of you display modes option page as well? The next things I would try are:

WARNING: Before doing any of the following, I would run “OptionsExport” and save out your current settings. This will not only allow you to get back to the way things were, but it will also provide me with something I can look at if any of the steps below actually fix the problem…because the cause will now exist inside the exported options file.

  1. If you have any custom display modes, delete them…then close Rhino and restart it…see if things work.
  2. If there are no custom modes and you still have the problem, I would then go through ALL display modes and delete them as well. Once all display modes are gone, close the Options dialog… At that point Rhino will detect that there are no mode and recreate all of them from scratch with their defaults. Now see if SetObjectDisplayMode works.
  3. If things still don’t work, then try starting Rhino in SafeMode and see if the command works… If it does, then it’s most likely that some 3rd party plugin is getting in the way of the command somehow (assuming you’re using 3rd party plugs).

If that still doesn’t seem to solve the problem, then the only other thing I can suggest is a complete re-install of Rhino…which also includes a complete wipe of Rhino from your system…including all Registry settings and cached user options and preferences. That’s a bit drastic, but at this point, I have no other suggestion… This is the only report of this problem, and nobody at McNeel seems to be able to reproduce it…and if we/I can’t reproduce it, then fixing it is going to be quite difficult.

Let me know if you discover anything… and again, if any of the steps above solve the problem, then I’d like a copy of the exported options file…because theoretically I should be able to import them here and experience the same problem.

Thanks for your patience on this.
-Jeff

Thanks so much. I start a job tmrw, so not sure I’ll be able to dive in on this or not.

Will let you know, and update you here.

Thanks,

So, I’d like to completely remove Rhino 6 from this system and reinstall. Can someone point me to step by step directions to make sure I 100% remove the current install so I can reinstall and hopefully cure my woes?

Thanks