SetObjectDisplayMode not showing all modes

unhandled

#1

SetObjectDisplayMode seems to not be showing anything but pre-canned modes. In the modes that are missing, Allow assignment to individual objects is checked, but they are still not showing up.

Thanks,
Sam


(Pascal Golay) #2

Hi Sam - the ones using Technical pipeline are not available per object as far as I can see - is that what these are? (i.e. Artistic, Technical, Pen and copies of these)

-Pascal


#3

No, the ones missing include those using OpenGL pipeline. Interestingly however, on some of my modes the only available pipeline is OpenGL (Windows and Technical2D are missing in the pull down). This does not seem to be affecting if they show up in SetObjectDisplayMode though, the only options I am seeing are Wireframe, Shaded, Rendered, Ghosted, XRay, Arctic, and UseView.

Sam


(Pascal Golay) #4

Yeah - new technical based modes work… I don’t know - can you export and send me one of the bad 'uns?

-Pascal


#5

Rendered Gradient w shadows.ini (11.5 KB)

There’s a bunch of them, let me know if you need anything else.

Sam


(Pascal Golay) #6

Hm - that one shows up here. Just as a test, try deleting it and re-importing from the ini. No idea why that should work but…

-Pascal


#7

Hmm, no luck. Copying one of the working ones didn’t work either. Perhaps I’ll try deleting them all and adding back one by one.

Hmm, in the ini if I set the order to a negative value, it will show. If it is positive, it will not.

Sam