Service update is unavailable

I have a problem with my SERVICE UPDATE of V6 sr22, since november 2019 the service is not working; I’ve read all the topics related to the problem, I’ve looked in task manager and mcneel update service 5.0 is running, I tried to uninstall and install my Rhino, but the problem is still there, what’s the matter?
ps my OS is an update win10


Hi - have you tried to manually stop and restart the service in the Windows Services manager?

Also, when you click the Check Now... link on the Rhino Options > Updates and Statistics page in Rhino, you should be able to manually download and install the newest version. We’ve seen instances where doing so fixes the problem with the update service.

I’ve reinstalled the program with a new download file, but I’ve still the same issue; is it necessary to remove all the Rhino folders in PROGRAMS and PROGRAM DATA?

How can I uninstall the whole program? and after install again? Thanks



Hi Francesco - you should only use the Windows Control Panel\Programs\Programs and Features panel to uninstall Rhino. You could first try a Change > Repair in that interface.

Hi, I use the control panel to uninstall but after this Rhino is working again! I attack below a screenshot of my control panel!
Actually Rhino works well, the problem was with the service update unavailable, but now there is a strange situation, can you help me?


Why do you think reinstalling Rhino will fix anything?

As Wim asked, is the McNeel Update Service running?

In Rhino Options > Updates and Statistics, are they Enabled?

Also, SR21 is the current Service Release. SR22 is the current Service Release Candidate.


I read old topics about this problem and one of the possibilities was to reinstall the program with a new download so I tried, but the weird is, though I uninstalled the program and it disappeared
in the control panel as in the attached image, Rhino is still working on my computer.
I installed the candidate version to solve the update service problem, but it didn’t work!

Before I uninstalled Rhino, McNeel update service was running and updates and usage statistics were enabled, so it was all right but no the update service; anyway this morning I’m working with Rhino, there’s no problem but it doesn’t appear in my control panel.

Next week I’m going to solve this question, any advice?



Francesco, let’s hear with the bigger brains…
@brian - Rhino was uninstalled on the system and there was no trace of it in the Windows list of programs to uninstall - and still it continues to run but always says that the update service is unavailable. Any pointers?

thank you so much

see you soon

Hi @fmataraz,

I’m not sure why uninstall didn’t remove Rhino completely. It may be that there are multiple installations on your computer?

Does it get better if you restart your computer?

What if you look in Control Panel for other Rhinos that didn’t get removed?

Are all your Windows Updates installed? Sometimes having a Windows Update fail can cause other things to fail to install or uninstall, too.

You might also try running Microsoft’s Fixit Tool for Installing and Uninstalling Programs to remove anything Rhino related.

If none of these work, please let me know. Manually cleaning this up is possible but tedious.

I tried with Microsoft’s fixit tool but it didn’t work… anyway I’ve just installed the win 10 update of january, I’ve just downloaded Rhino release 6.22, but I haven’t installed it yet because I’d like to uninstall the old version, candidate 6.22 and WIP, which both run but don’t appear on TASK MANAGER.

I’ve restarted many times but it doesn’t get better.

Where can I find hidden installation of Rhino?



Hi Francesco - just letting @brian know that you have answered…
(I see that you answered by eMail and I don’t think that Brian is getting notified when a post is answered that way).

I don’t know. There’s not enough information in your reply to tell me what’s going on.

Are you saying that Microsoft’s Fixit tool doesn’t show anything related to Rhino?

I suggest that you install Rhino 6.22, and if that works, great! If not, I’ll have to do a remote session with you and try to figure it out.

(@wim I do get notifications when replies come in via email, but I tend to check Discourse every day or two).

Hello, i have the same problem (?)

Update service is running. The problem is for RH7 and RH6 too… this problem form latest month of old year…

Same issue. After installing RH7, McNeel Update Service 5.0 running, Rhino shows Update and Statistics grayed out and Rhinoscript DLL fails to load.

Would appreciate some guidance.

Same thing here, RH_7.2 Update Service is not working

So, here sits the worm
Two circumstances meet

  1. Enable Updates and Usage Statistics is unchecked
    StringKey “Enabled” Value gets set to 0

and at the same time

  1. Insecure port 25 is blocked by router or firewall
    McNeelUpdateService.exe calls to port 25,
    Port 25 is closed McNeelUpdateService.exe interprets and reports to Rhino “no internet connection for Updates and Usage Statistics”.

If port 25 remains closed, you can only start updates manually.
Here problem one, activating the “Update Checkbox” works only via the above mentioned registry key!

So press WIN + R, write regedit and hit Enter, navigate to HKEY_LOCAL_MACHINE\SOFTWARE\McNeel\McNeelUpdate
Set key “Enabled” to 1
Now, start Rhino go Help -> Check for Updates… -> Check Now…

Next Problem, If port 25 remains closed, after RH_SR_Update
StringKey “Enabled” Value gets again set to 0 and checkbox is only accessible over registry

At moment “Not blocked port 25” fixes this worm or updates needs to start manually.

Translated with (free version)


Yop! You are the best :slight_smile: Is working.
After install SRP are service unavailable again…

Port 25? That’s SMTP. I would understand this if you had said port 123 (NTP) or 433 (HTTPS). But I’m really baffled why there’d be any call on port 25. Are you certain that’s the right port in your explorations?

@Chita I’m glad it worked :wink:

Yes, tested, port 25 closed, update service not work !!!

EventViewer says:
Error,Internet access is disabled. McNeel Update Service will not start.,7.2.21005.13001

This has been earlier reported by @Michael_Meyer

I think it comes from NetFrame and one of the called dll’s uses port 25