"serial port could not be opened" message with microscribe

Hi there,
I have a microscribe arm which has worked successfully with rhino for a number of years.
However, it appears that Win 10 has recently scuppered this.
I have a Prolific Serial Port to USB connector, as well as drivers to run it.
In the past this worked fine, but now Rhino gives the message “Serial Port could not be opened”, even though there are COM ports visible in the Devices panel.
I have searched the web for answers, and I see there is stand-alone software available for setting up virtual serial ports.
Does anyone have any experience with this?
All advice is gratefully received.
Regards
Mike Logan

this link likely does not answer your question directly, but it does have a contact at microscribe you may use to get the answer-

https://discourse.mcneel.com/t/microscribe-g2x-with-rhino-6/79143/2

Thanks Kyle,
I will investigate and see if they can shine a light on what is happening.
Appreciate your help.
Kind regards
Mike Logan

Hi Mike - it may be worth running a Repair on the Rhino installation and reinstalling those Serial to USB drivers, maybe check for an update to those as well.

-Pascal

SOLVED!
Dear Rhinos,
After lots of investigation I have finally solved this problem, although I am not sure why the first part worked.
First part… I downloaded Virtual Serial Port Driver software by Eltima Software 14 day demo.
I set up a pair of virtual serial ports, COM1 and COM2.
By doing this the Error message in Rhino 6 changed from “Cannot open serial port” to “Cannot detect Microscribe”.
Hmmmm, some sort of progress.
With some more searching I found the following advice on an obscure webpage, pasted below.

Microscribe 3DX Setup Instructions (win7 64 bit)
1. Connect Cheap USB to Serial Adapter from E-Bay to Microscribe Serial Plug.
2. Plug in USB adapter, drivers will install automatically
3. Go to Start, Type “Device Manager” in search box and click to open
4. Scroll down to “Ports (COM & LPT)” and click to expand
5. Double click on “USB Serial Port”
6. Select “Port settings” tab in properties window.
7. Set BPS to 4800
8. Click “Advanced”
9. Set Com Port Number to “COM 1”
10. In Rhino, Tick “3D Digitising” Toolbar
11. Turn on Digitiser if not already on and click “Connect Digitiser”
12. Select “Microscribe Digitizer” from selection box in pop-up
*13. If successful, you can proceed, if not Rhino will hang up at this point. I think it hangs because it cannot find the port or if the Baud rate is too fast?

Now I deleted the virtual COM1 and COM2 serial ports and changed the USB Serial port as per the above instructions.
And now the Microscribe works!! Yay!!

It almost seems like setting up the virtual ports cleared out the pipes between Rhino and Windows 10, and then it was a case of changing the Baud rate settings and resetting the COM port from 30 to 1.

I hope this info helps someone else, and i appreciate the suggestions that other members made.
Kind regards
Mike Logan

Hi Mike,

We just cleaned of ours and had the same problem. Virtual Ports are not necessary, old school RS com port was com1 so like you said forcing the speeds and port# in device manager does the trick. I have another issue now mainly caused by a bad memory…will try to PM you somehow for a little help if possible?

Best, Paul

Hi Paul,
When you say your results from the Microscribe are all over the place, can you describe what is happening? I am assuming you are calibrating prior to use, because you are really forced to setup correctly by the program.
Just in case, I will let you know what I do.
I get a set-square and mark up the surface that is going to support the item to be scanned. I make a mark at the vertex (the point where the 2 right angles meet}, and a point at the end of each right angle on the set-square. So when calibrating the Microscribe Rhino asks for the origin, then the x axis, and then the y axis.
So I just choose the vertex point as origin, and one point at the end of each arm as the x and y point, just like you would see in the bottom left corner of the Top window of Rhino.
Then Rhino asks for World origin, I just hit enter button to choose the default.
You should be ready to start.
I choose Curve:interpolate points and begin inputting my information. If you have a foot pedal right pedal chooses your next input point, and left pedal is equivalent of hitting enter button to finish the input.
Sometimes you will find that if you are scanning a flat piece it will be a bit up and down in the z direction.
All you need to do is select the curve you have scanned in and project down to the construction plane to get it dead flat.
Please let me know if this helps or if you have separate issues that aren’t addressed here.
regards
Mike Logan