Selecting linear or aligned dimension (BUG?)

  1. Drop a dimension in your drawing
  2. Select it
  3. Enjoy not being able to zoom in with your mouse wheel or nudge it until you pan your view.

I’m not seeing that here (same version). --Mitch

I suspected it might be my machine, hence (BUG) is in parenthesis. :frowning:

What is your video card/driver situation?

4 machines out of 6 have this problem in our office. All nVidia cards, all different drivers.

Hmmm. OK, that’s interesting, I’ll have to try that on a couple of other machines here. Just place a linear dimension and then select it? Nothing else special going on? Custom display modes, plug-ins, something…? --Mitch

Nothing special. It doesn’t matter if it’s a parallel or perspective view. Just don’t pan or zoom right after you place a dimension (it only happens to linear or aligned ones). If you do, everything works as intended.

If I use macro where it selects the dimension after i place it - everything works as intended.

Just checked the rest of the machines. 4 out of 8 have the problem. It also doesn’t matter how you select it (clicking or box).

Hm. Not seeing that here so far. AMD graphics though.


Weird, not seeing here either. I have a Geforce GT 330M.

Nvidia K2000, normal behavior here.

In your video, there are multiple “PAUSE” on the commandline between steps of the dimension command. I don’t have those, are you sure you aren’t running some macro? Still don’t know why that would matter, though.

^ yeah I’m running macro to drop the dimension and select it afterwards, but it doesn’t matter 'cause I can deselect it, select it again and then I won’t be able to zoom with the mouse wheel until I rotate or pan my view. 3D pilot though works fine.

It almost feels like when I select the dimension the focus switches to something else… Properties Window?.. 'Cause when I click on the selected dimension again (shift the focus back into model space) zoom works just fine. Does it make sense?

Yep, that’s it. As soon as I turn off Properties window everything works just fine. Basically, when I select linear or aligned dimension the focus switches onto Properties window and I have to click inside the model space to return it there.

I don’t know if it matters, but I have two 750 cards each driving its own monitor.

Hi Asterisk- does it behave if you disconnect the 3DPilot?


^ Nope. The only way of “fixing” it that I found is to turn off Properties window, but that’s like poking one of your yes out. :smiley:

I wonder if anyone at McNeel was able to reproduce this behaviour. :confused: