Dimensions still moving when clicking in and out of viewport - Can I lock the viewport?


#1

Ok, so this has been a problem for a long time. Dimensions get crazy when I click into a viewport and back out - even if I don’t mess with geometry having to do with the dimensions.

Is this ever going to be resolved? Sorry, but it makes my day hell, and I don’t want to have to do everything in model space.

Is there a way to actually lock myself out of clicking into the viewport? (I’ve tried locking the layer, locking the object of the viewport. Still end up clicking in if I’m ever working with text, etc on top of viewport)

Thanks


(Pascal Golay) #2

Hello - it’s not clear to me what you’re describing - are you clicking on layout details, or viewports? I’m guessing details. By ‘clicking into’, do you mean you snap a dimension to a location in a detail but the active space is Layout?

-Pascal


#3

This has been improved in recent release candidates, if you are still seeing it, I’m sure Lowell would love an example. As a work around try SelDim PurgeHistory

San


#4

Hey Pascal

Sorry - Im probably still using Vectorworks language.

I do indeed mean Detail. And Im saying I have dimensions in paper space. When I double-click INTO the detail and back out to paper space again, one or more of my dimensions flies off into infinity.

@SamPage - thx for the suggestion. The bad thing about that is I lose the connection between the geometry and the dimensions, so if I change this of something in model space, the dimension doesn’t change with it.


#5

Sorry, @pascal, but did you catch my reply to this? If the answer is just that it’s going to be that way for a while, just let me know so I can adjust my workflow


(Doaa Alsharif) #6

Hi @Alan_Farkas,

A few things i want to check here:
1- which version of Rhino are you using? can you type systemInfo and save the result as a text file and attach it here?
2- Are model space scaling and layout space scaling enabled/disabled? you can find it under
Tools > options > Annotation Styles under delete on the right.
3- it would be great if you can send us a screenshot of the issue.

Thank you


#7

Hi @doaa,

Thanks for the hand.

SCALING: Modeling=On Layout=Off

SCREENSHOTS ATTACHED (x3)

SysInfo:

Rhino 6 SR7 2018-7-9 (Rhino 6, 6.7.18190.21071, Git hash:master @ 654ce722d585b1abd1b4633541186d829111878b)
Licence type: Commercial, build 2018-07-09
License details: Cloud Zoo. In use by: Alan Farkas ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-NUQN85K

GeForce GTX 980 Ti/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 391.35)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-23-2018
Driver Version: 23.21.13.9135
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 6 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.7.18190.21071
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.7.18190.21071
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.3.1.650\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.7.18190.21071
C:\Program Files\Rhino 6\Plug-ins\import_SKP.rhp “SketchUp Import”
C:\Program Files\Rhino 6\Plug-ins\export_PDF.rhp “PDF Export” 6.7.18190.21071
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.7.18190.21071
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.7.18190.21071
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2017.10.16.484\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”


(Doaa Alsharif) #8

@Alan_Farkas Thank you for the info, How about the other two options?


(Doaa Alsharif) #9

@Alan_Farkas I am trying to recreate the issue here. Here is what i am doing:

  1. Draw a box.
  2. Create a layout with 4 details.
  3. Add dimensions on each detail by double-clicking on it.
  4. Double click again to leave that detail.
  5. Lock the Detail.

Does that sound right? An images or a gif/video of the issue would really help.
Thank you


#10

It doesn’t always happen. Files that I have more going on in model space, I think it happens more.

I just noticed this oddity - and the weird line that pops up is exactly the spot where the “dim to infinity” in the still images ends up.

EDIT: Also, that weird line DOES NOT show up when I’m NOT USING Continuous Dimension
Don’t know if that has anything to do with “Dims to Oblivion” or not


(Doaa Alsharif) #11

@Alan_Farkas
Are you adding the dimensions inside the details? meaning is the detail active?
Try double-clicking on the detail, add the dimensions then double-click again to de-activate the detail.
Will that work?


(Mary Ann Fugier) #12

Hi Alan,
This was bug RH-44726 in Rhino 6 sr0-sr3 of the first versions of Rhino 6. It was fixed in sr4.

However, dimensions that were create these a earlier versions of 6 with the obsolete history are still being affected and can not be fixed. It also seemed worse when created on a layout and the geometry that was snapped to was a hatch. Also dimension you make in Rhino 6 v7 will not have this issue.

They will continue to update strangely as you double click in and out of the detail views…

You can delete and recreate them.
As @SamPage recommended, Seldim and PurgeHistory works.
I also to this to accomplish the same. It seems quite fast with the short cut keys.
You will need to do this in model space and on each layout.

  1. Seldim
  2. Control x to cut them (Cut)
  3. Control v to paste them back. (Paste
  4. During the paste the History will be striped from the object

You should hopefully see the issue resolved in your model at that point.
Let me know if this helps.

Sincerely,
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA


#13

I create a new file from an “older Template” (one that I created from an earlier Release), but there ARE NO DIMENSIONS in that template. Should I be getting this problem?


#14

I’m creating dimensions in Layout space (not in activated/live detail)


(Mary Ann Fugier) #15

Hi Alan,
Thanks for the details.
Yes- I understand. You are creating the dimension on the layout not in the activated details.
Question: are you picking on the end pt or other location with an osnap? (if is hard to tell in the video, but I do not see the osnap marker.)

I need the file that you used in the attached video and your template.
I will use your exact procedure, and see if I can duplicate it here.
If your prefer, feel free to email it to me mary@mcneel.com and not post it to the thread.
Unfortunately, I tried to duplicate this with my own files with no success.

It looks so similar to RH-44726. but then again may be a different issue.
I am concerned because it appears that you are picking on a hatch object, and that was one of the situations where the previous bug was seen.
That is what I want to test.

This is really a copy of the file. So if the template is corrupt, the new file will be corrupt too.

Looking forward to getting your file.
Sincerely,
Mary Ann Fugier